Password for Web interface doesn't work

Whenever setting the password for the web interface ( root_password_sha2), it doesn’t seem the accept the password that I either hashed or in plain text.

  • OS Information: Ubuntu 20.04 LTS

  • Package Version: Graylog 4.2

  • Service logs, configurations, and environment variables:

password_secret = ECG27k3nqcYFJPU7WNCyvD6TslPTjrs8pzXrWYpqkbU7pR9iKtzhRQQecocyutiQT33fyPNOIGD3ePaOVPlT9hTFuReFqHK

# The default root user is named 'admin'
root_username = admin

# You MUST specify a hash password for the root user (which you only need to initially set up the
# system and in case you lose connectivity to your authentication backend)
# This password cannot be changed using the API or via the web interface. If you need to change it,
# modify it in this file.
# Create one by using for example: echo -n yourpassword | shasum -a 256
# and put the resulting hash value into the following line
root_password_sha2 = 0fd25c61a9504670e24334d6c5fb6c07a50aef89802a73a9ab20007a3ec778be

I tried to change the root_password_sha2, the root_username, creating new passwords with the given options on the forums and in the config file.

Anybody has with some other options that can be done?
Also, if more information is necessary, let me know, so I can edit it.

you can create a new password with this command.

echo -n $YOURPASSWORD | shasum -a 256

and paste upper command output on line root_password_sha2

then run this commans

systemctl restart graylog-server

check your service with this command

systemctl status graylog-server

then u can login web ui with user:admin password:$YOURPASSWORD

I have done that, but it keeps repeating the login prompt. It does not work.
The password gets hashed, but whenever I use the unhashed thing, it once again prompts for login credentials.

maybe u can reboot your system and try again.

reboot now

Hello @Wakkolotty @rabia
just chiming in. I had that happen before, it was the password used.

Example of a password that worked.

echo -n password | sha256sum

Example of a password that didnt work

echo -n P@$$word!@# | sha256sum

To make the last example work I had to quot around my password

Example fix.

echo -n 'P@$$word!@#' | sha256sum

It a Linux thing, also insure you didn’t add white space.

Hope that helps

Thanks for the option, I’ll give it a try. I have tried my own password, without the quotation marks, which could be the issue.

1 Like

I have tried this, to no avail. The prompt for the login credentials keeps coming back. I tried different passwords, updated the root_password_sha2 accordingly, but the prompt keeps showing up, asking for login credentials.
The logs don’t show anything regarding this, but they do show the error of not being able to find the correct path to the Self Signed certificates. I am 100% sure these are the correct paths (/etc/graylog/server/cert.pem and /etc/graylog/server/pkcs8-encrypted.pem).


Your using HTTPS?
If so, I would need more information on how you set u your certs and Graylog configuration.

Yes, it automatically goes for HTTPS. But currently, there are some other issues which I have to resolve. This topic can be closed, as it is no longer relevant.
Thank you for your time and patience.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.