Graylog using blank screen on web interface

Hi all,

I’ve managed to get Graylog running on a server and the Graylog Web Interface loads as expected using an internal IP address but shows a blank screen when using our external IP address (http: //178.238.141.207:9000). Any idea what may be causing the issuing? Perhaps something that I’ve omitted in the server.conf file. I’ve provided an error snapshot here.

Below is snippet of the server.conf which I believe is the relevant section.

#### HTTP bind address
#
# The network interface used by the Graylog HTTP interface.
#
# This network interface must be accessible by all Graylog nodes in the cluster and by all clients
# using the Graylog web interface.
#
# If the port is omitted, Graylog will use port 9000 by default.
#
http_bind_address = 0.0.0.0:9000

#### HTTP publish URI
#
# The HTTP URI of this Graylog node which is used to communicate with the other Graylog nodes in the cluster and by $
# clients using the Graylog web interface.
#
# The URI will be published in the cluster discovery APIs, so that other Graylog nodes will be able to find and conn$
#
# This configuration setting has to be used if this Graylog node is available on another network interface than $htt$
# for example if the machine has multiple network interfaces or is behind a NAT gateway.
#
# If $http_bind_address contains a wildcard IPv4 address (0.0.0.0), the first non-loopback IPv4 address of this mach$
# This configuration setting *must not* contain a wildcard address!
#
# Default: http ://$http_bind_address/
#http_publish_uri = http ://178.238.141.207:9000/

#### External Graylog URI
#
# The public URI of Graylog which will be used by the Graylog web interface to communicate with the Graylog REST API.
#
# The external Graylog URI usually has to be specified, if Graylog is running behind a reverse proxy or load-balancer
# and it will be used to generate URLs addressing entities in the Graylog REST API (see $http_bind_address).
#
# When using Graylog Collector, this URI will be used to receive heartbeat messages and must be accessible for all c$
#
# This setting can be overriden on a per-request basis with the "X-Graylog-Server-URL" HTTP request header.
#
# Default: $http_publish_uri
#http_external_uri =  http ://178.238.141.207:9000/

#### Enable CORS headers for HTTP interface
#
# This is necessary for JS-clients accessing the server directly.
# If these are disabled, modern browsers will not be able to retrieve resources from the server.
# This is enabled by default. Uncomment the next line to disable it.
#http_enable_cors = false

#### Enable GZIP support for HTTP interface
#
# This compresses API responses and therefore helps to reduce
# overall round trip times. This is enabled by default. Uncomment the next line to disable it.
#http_enable_gzip = false

# The maximum size of the HTTP request headers in bytes.
#http_max_header_size = 8192

# The size of the thread pool used exclusively for serving the HTTP interface.
#http_thread_pool_size = 16

################
# HTTPS settings
################

HTTP bind address

The network interface used by the Graylog HTTP interface.

This network interface must be accessible by all Graylog nodes in the cluster and by all clients

using the Graylog web interface.

If the port is omitted, Graylog will use port 9000 by default.

http_bind_address = 0.0.0.0:9000

HTTP publish URI

The HTTP URI of this Graylog node which is used to communicate with the other Graylog nodes in the cluster and by $

clients using the Graylog web interface.

The URI will be published in the cluster discovery APIs, so that other Graylog nodes will be able to find and conn$

This configuration setting has to be used if this Graylog node is available on another network interface than htt

for example if the machine has multiple network interfaces or is behind a NAT gateway.

If http_bind_address contains a wildcard IPv4 address (0.0.0.0), the first non-loopback IPv4 address of this mach

This configuration setting must not contain a wildcard address!

Default: http ://$http_bind_address/

#http_publish_uri = http ://178.238.141.207:9000/

External Graylog URI

The public URI of Graylog which will be used by the Graylog web interface to communicate with the Graylog REST API.

The external Graylog URI usually has to be specified, if Graylog is running behind a reverse proxy or load-balancer

and it will be used to generate URLs addressing entities in the Graylog REST API (see $http_bind_address).

When using Graylog Collector, this URI will be used to receive heartbeat messages and must be accessible for all c$

This setting can be overriden on a per-request basis with the “X-Graylog-Server-URL” HTTP request header.

Default: $http_publish_uri

#http_external_uri = http ://178.238.141.207:9000/

Enable CORS headers for HTTP interface

This is necessary for JS-clients accessing the server directly.

If these are disabled, modern browsers will not be able to retrieve resources from the server.

This is enabled by default. Uncomment the next line to disable it.

#http_enable_cors = false

Enable GZIP support for HTTP interface

This compresses API responses and therefore helps to reduce

overall round trip times. This is enabled by default. Uncomment the next line to disable it.

#http_enable_gzip = false

The maximum size of the HTTP request headers in bytes.

#http_max_header_size = 8192

The size of the thread pool used exclusively for serving the HTTP interface.

#http_thread_pool_size = 16

Your help and input would be greatly appreciated. If you need any more information regarding the above then please let me know and I’ll be willing to assist.

Best regards,
Mike.

You have set those options however, you haven’t un-commented the lines so, your values aren’t being applied.

Hi

Thanks for your prompt response I’ve un-commented those the lines as described but still get the same issue.

Another issue I forgot to mention in my original post is that I can’t send any logs to the Graylog Inputs with the settings 'GELF/UDP’. I’ve also provided the relevant IP address too. Any idea why that might be happening?

Thanks and best regards,
Mike.

Have you made all the adjustments with rules/ports/NAT etc with your firewall? Describe the entire path the data should take take. If your inputs aren’t receiving (Your other post) it is likely the same issue with how you have your firewall set up? Be careful to remove data in your posts that the public shouldn’t see… more detail always helps - particularly if it is formatted.

Hello,

Thanks for all your suggestions, we’ve managed to resolve the issue. The problem was with how Graylog was setup on our webhost’s server. The javascript files which is responsible for rendering the Graylog user interface was prefixed with our webhost’s internal IP number, so even though we used our external IP number to load the Graylog web interface, it still made no difference. In the end we contacted our webhost to create a domain name for our Graylog server and that seemed to fix it.

Hope this helps anyone else having similar issues.

Best regards,
Mike.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.