Problem Accessing Graylog webinterface via NAT


I’m currently trying out Graylog. I am trying to set it up so that it can be accessible outside via NAT. Currently I have set my router to allow port 9000 and point it to the same port of the server. I can access the web interface via local lan without problems but when accessing it via the internet I just get a blank screen. I would much appreciate any help. Kindly see details on my installation below:

Ubuntu 16.04
Graylog 3.1.2
Elastic Search 6



The same here. Browsers Firefox on Windows 10, and Chrome on Android.

Ok, got it. You should set http_external_uri = http://your-external-ip:9000/ in server.conf file.

Thanks Karlis will try to do that.

this community has already multiple options for that. But in the end you need to have the http_external_uri or a specific header that points your browser to the Graylog API to retrieve data.

Hi Jan,

I was able to make it work using the DNS fix.

Thanks for the follow up.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.