Server currently unavailable for NAT IP


(Jimit Salvi) #1

Hi,
We are using NAT to access the graylog running in Private IP space. I am able to access the graylog web gui from the Private subnet, I also get the front page when accessing the graylog from Public subnet but it says

We are experiencing problems connecting to the Graylog server running on http://192.168.32.139:9000/api/. Please verify that the server is healthy and working correctly. I can access the elasticsearch but not the graylog login. Am I missing something here?

show ip nat translations | i 135.16.X.X
— 135.16.X.X 192.168.32.139 — ---
tcp 135.16.X.X:9000 192.168.32.139:9000
tcp 135.16.X.X:9200 192.168.32.139:9200


Server currently unavailable for NAT IP issue
(Jimit Salvi) #2

I can access elasticsearch which tells me the NAT is good.


(Jimit Salvi) #3

Can access the gui from private address space.


(Jan Doberstein) #4

you should reread the Documentation about the Webinterface.

http://docs.graylog.org/en/2.3/pages/configuration/web_interface.html

Your Browser need to be able to connect to the Graylog API - what is not possible if you connect to a Public IP and the API is located on the Privat Network that is not reachable.

You should look into the details on this part how you can configure your setup to make it work.

HINT: Run a proxy like NGINX on the nat’ed Interface that would be the fastest option.


(Jimit Salvi) #5

Hi Jan,
Yes, I got it working with the NGINX using the above guide.

Thanks.


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.