Graylog server with public and private IPs

Hey guys, i’ve searched the forums for similar issues and have not had any luck with this one, so hoping someone can point me in the right direction. Public IP obscured purposely.
I have a new graylog server with 2 IPs, one internal ( and another external ( I would like to be able to access the graylog UI from the public IP.
I have set the http_bind_address to and can see that graylog binds to it using netsat, but I am unable to get the UI to load. The public IP is reachable and firewall access to port 9000 is setup.
When I set the bind address to the internal IP the graylog UI comes up without issue.
I have also tried setting http_bind_address to and http_publish_uri to the public IP but no joy.
Can anyone suggest anything else?
Thanks in advance!

I have a setup where graylog has both a public and private. However, we didn’t add another interface onto graylog but instead relied on a 1 to 1 nat on our firewall to take care of the dirty business. This way inside the office we resolve to the local lan and outside we rely on a public.

Probably not the answer you were looking for but i figured I’d share my setup to see if it’s an option for you.

Hi acl, thanks for sharing. I suppose I could use HAProxy as a reverse-proxy to accomplish the same thing. It would actually be the safer solution since graylog would continue to use an internal IP.
Thanks for the suggestion.

what are you settings for http_* in your graylog server.conf @sipengines?

From what Network you want to connect to Graylog?

My guessing is you want to be able to connect to Graylog via the internal and the external IP - what is native not possible.

You should/must work with a proxy that is able to listen to both interfaces and configure the header modification according to your vhosts. Means like written in the docs:

But one vhost for the internal and one for the external ip, will do the trick.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.