Unable to access web interface from the same network

Hello All, I am new to Graylog. I am unable to access the server via the web interface. I recently install ed Graylog on Ubuntu 19.10. In the config under http settings I made some changes and restarted/enabled both elastic search and Graylog server. I have even rebooted several times.

I will like to access Graylog from both the same machine it is on as well as from other machines on the same local network. I can access the web interface if I set everything to 127.0.0.1.

Any help is appreciated.

Here are the changes I have made (I have also tried different combinations):

http_bind_address


#Default: 127.0.0.1:9000
#http_bind_address = http://127.0.0.1:9000
#http_bind_address = [2001:db8::1]:9000

#Changed to the local ip address
http_bind_address = http://10.0.0.237:9000

http_publish_uri


Default: http://$http_bind_address/

http_publish_uri = 10.0.0.237:9000

http_external_uri


Default: $http_publish_uri

http_external_uri = 10.0.0.237:9000

Please let me know which of these I am getting wrong and also if there is anything else besides these that I need to check.

please show output of

ip -br a
lsof -Pni :9000

ip -br a:

lo UNKNOWN 127.0.0.1/8 ::1/128

enp0s25 UP 10.0.0.237/24 2601:2c7:580:6190::b3f8/128 2601:2c7:580:6190:24ed:2ec2:bf48:7c5f/64 2601:2c7:580:6190:e7e5:a8ae:f9e0:a382/64 fe80::4e2f:a9d9:664e:3fb3/64

lsof -Pni :9000:

blank (no output)

Thanks…

Correct
http_bind_address = http://10.0.0.237:9000
to
http_bind_address = 10.0.0.237:9000

Hi zoulja,

Thanks! I made those changes and still not able to access from the same machine. I have included some screenshots.

A screenshot of terminal (ifconfig)

screenshot of config file

Hello All,

I am able to access it now! Thanks.

I put back the hash tags in front of http_publish_address and http_external_url so that they defaulted to the bind address and it is working now.

Thanks

he @judel5

http_bind_address is an adress - like written EVERYWHERE and http_publish_uri and http_external_uri are URLS - that need the protocol added. Like written above the setting in the configuration file OR the documentation …

The default will add this silently … but if you but in a value that is used.

You would have seen that in the Graylog server.log …