Problem sending logs to Graylog Inputs from external source

Hi,

We currently have Graylog running on a server and we’re having issue sending logs to Graylog inputs on that server. The mode we’re using is ‘GELF / UDP’. We believe the issue is linked to another issue that I’ve raised in another post here’s the link for further details.

I’ve also attached snapshot of our current Graylog input snapshot for reference.

Any help or suggestions would be greatly appreciated.

Best regards,
Mike.

Is there a reason you are binding the input to accept data on the loopback address?

Hello,

No, I thought that was the default address used as shown in the examples. Perhaps something I inadvertently overlooked. Should it be the same as the server IP address?

Thanks for your reply and suggestion so far

Best regards,
Mike.

You could set it to the IP of the server or to 0.0.0.0 (which could be a security issue depending on how stringent you need to be).

Hello, yes I did use the server IP number and the 0.0.0.0 number before , but had no joy, hence why I tried using 127.0.0.1.

This isn’t is a problem when I run it locally on my dev machine. Anything else I could have left out?

Thanks for your suggestions so far.

Best regards,
Mike.

have you opened the firewall ports?

Hi All,

Thank you all for your input and suggestions so far on the related issue. The good news is that we managed to resolve it. I’ll explain the cause of the problem and the steps we took to solve the issue. The problem to start with was the “input” port number 12201 being blocked on our webhost’s server.

In our bespoke applications, the config was pointing to the Graylog server’s ip number. We created a domain name for our Graylog server and replaced the ip number with that instead, which allowed us to log messages directly onto Graylog. As for the input settings we set the bind address to 0.0.0.0 - this may be subject to change in the foreseeable future.

Hope this helps anyone else who’s having similar issues.

Thanks and best regards,
Mike.

1 Like