Graylog could not execute search


(firmen) #1

Hello,
i have problem when i following steps no. 4


here the error

here the logs:

2018-03-19T16:43:33.963+07:00 INFO [CmdLineTool] Loaded plugin: Enterprise Intput 2.2.3 [org.graylog.plugins.beats.BeatsInputPlugin]
2018-03-19T16:43:33.960+07:00 INFO [CmdLineTool] Loaded plugin: Collector 2.2.2.3 [org.graylog.plugins.collector.CollectorPlugin]
2018-03-19T16:43:33.963+07:00 INFO [CmdLineTool] Loaded plugin: Enterprise Integration Plugin 2.2.3 [org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin
2018-03-19T16:43:33.964+07:00 INFO [CmdLineTool] Loaded plugin: MapWidgetPlugin 2.2.3 [org.graylog.plugins.map.MapWidgetPlugin]
2018-03-19T16:43:33.969+07:00 INFO [CmdLineTool] Loaded plugin: Pipeline Process plugin
2018-03-19T16:43:33.971+07:00 INFO [CmdLineTool] Loaded plugin: Anonymous Usag$s Usage Statistics 2.2.3 [org.graylog.plugins.usagestatistics.UsageStatsPlugin]
2018-03-19T16:43:39.255+07:00 INFO [CmdLineTool] Running with JVM arguments: nts: -Xms1g -Xmx1g -XX:NewRatio=1 -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:C -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:+UseParNewGC - ewGC -XX:-OmitStackTraceInFastThrow Dlog4j.configurationFile=file:///etc//graylog/server/log4j2.xml -Djava.library.path=/usr/share/graylog-server/lib/sigar -Dgraylog2.installation_source=deb
2018-03-19T16:43:39.632+07:00 INFO [Version] HV000001: Hibernate Validator null
2018-03-19T16:43:47.556+07:00 INFO [InputBufferImpl] Message journal is enable
2018-03-19T16:43:47.584+07:00 INFO [NodeId] Node ID: 27488ba8-de26-4bea-9bb8-a9bb8-a05dc4888705
2018-03-19T16:43:47.797+07:00 INFO [LogManager] Loading logs.
2018-03-19T16:43:47.799+07:00 INFO [LogManager] Logs loading complete.


(Jan Doberstein) #2

you should not use that old version - we are currently with Graylog 2.4.3 and you should use that.

depending on your OS you can use one of our official step-by-step guides for the installation.

I guess you do not have Elasticsearch installed or a not compatible version.


(firmen) #3

is it okay if i upgrade graylog version? or i have to re-configure?


(Jan Doberstein) #4

following the upgrade guides you are able to upgrade from your given version to the latest:

http://docs.graylog.org/en/2.4/pages/upgrade.html

Just take care that you first move over to 2.3 and after that to 2.4 - just because this is the supported way.

regards
Jan


(firmen) #5

but i installed in debian. can you suggest me any sources?


(Jochen) #6

http://docs.graylog.org/en/2.4/pages/installation/os/debian.html


(system) #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.