Graylog error: loading field information failed with status 500


(Bahman) #1

I try to upgrade graylog in docker from version 2.2.3-1 to 2.4.6-1 on ubuntu .
i used following command
docker run --link mongo --link elasticsearch -p 9000:9000 -p 12201:12201 -p 1514:1514 -e GRAYLOG_WEB_ENDPOINT_URI=“http://my-ip:9000/api” -d graylog/graylog:2.4.6-1
after that i start docker-compose up -d
and login to gralog.
det problem is i can’t search.


(Jan Doberstein) #2

what is the error you are facing?

Did you checked the upgrade nodes for breaking changes?

http://docs.graylog.org/en/2.5/pages/upgrade.html


(Bahman) #3

yes i did. mongo is version 3, and elasticsearch is version 2. It’s support elasticsearch version 2X.
Error is unable to perform search query. and search status code is 500.
search respond is
cannot GET http://“server-name”:9000/api/search/universal/relative?query=bolig&range=300&limit=150&sort=timestamp%3Adesc (500)


(Jan Doberstein) #4

did you notice the changes in 2.3 ( http://docs.graylog.org/en/2.5/pages/upgrade/graylog-2.3.html ) the changed way Graylog connects to Elasticsearch.

Also the special note what you need todo after you upgrade graylog?


(Bahman) #5

no. it’s look like i need to upgrade elasticsearch.


(Bahman) #6

ok i rebuild elasticsearch and upgrade elaticsearch to 6.5.4
i try to login to graylog i get error: The server returned : 400 - cannot post http:“servername”:9000/api/system/session (400)

Please Help!


(Bahman) #7

ok i login should write domain name also. but the same problem cannot search and search code s 500


(Bahman) #8

Loading of sources data failed with status : error: cannot Get http://…:900/api/sources?range=3600 (500). Try reloading the page.

and

could not retriev index.sets.
feaching index sets list failed: unable to read information for indices [graylog_*]


(Jan Doberstein) #9

it looks like your Graylog is not able to connect to your Elasticsearch.

Without knowing your configuration it is not possible to help you in any other way than pointing to the documentation and the docker setup page where working configs are given:

http://docs.graylog.org/en/2.5/pages/installation/docker.html


#10

GL 2.4 won’t work with ES 6.x
You need to update the GL’s config, not ES


(Bahman) #11

what i did was. i stop docker-compose, then i

docker run --name elasticsearch -e “http.host=0.0.0.0” -e “xpack.security.enabled=false”
-d docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4
then i
get the gl:
docker run --link mongo --link elasticsearch -p 9000:9000 -p 12201:12201 -p 514:514 -p 5555:5555
-e GRAYLOG_WEB_ENDPOINT_URI=“http://127.0.0.1:9000/api” -d graylog/graylog:2.5
Then i try to start docker-compose.
i can see all steam and all alert and ,…
But not search. i can’t search:
error: cannot get http://…:9000/api/source?range=3600 (500)


#12

Does elasticsearch run well?
Do you see indices?
What do you see in GL & ES logs?

//Before you copy these infromation please read and construe it.


(Jan Doberstein) #13

-e “xpack.security.enabled=false”

that is not needed when you run elasticsearch oss … no xpack is given and elasticsearch will not start with a setting it does not understand … so it looks like elasticsearch is not running IMHO


(Bahman) #14

ok jan,
it was in “quick start” from graylog instructionpage.
I try to install elasticsearch with this command.
docker run --name elasticsearch
-e “http.host=0.0.0.0” -d docker.elastic.co/elasticsearch/elasticsearch-oss:6.5.4


(Jan Doberstein) #15

fixed that … in the docs

So what is your current status?


(system) closed #16

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.