Not able to search after upgrade to 2.2.3-1 from 2.1.2-1


(Libincheeran) #1

I upgraded Graylogserr2 from 2.1.2-1 to 2.2.3-1 running using docker. Now I can’t see any of the saved searches and streams. I don’t see any error message in the logs. There is an error message popping up on screen with the following message “Fetching saved searches failed with status: TypeError: Cannot read property ‘toJS’ of undefined”

Any help is appreciated.


(Jochen) #2
  • How exactly did you install and upgrade Graylog?
  • Are you running multiple different versions of Graylog in your cluster?
  • Have you tried clearing your browser cache?

(Libincheeran) #3

Graylog is installed using Docker.I have a docker-compose yaml file and updated the image to “graylog2/server:2.2.3-1”. Graylog server is running on single node. I had stopped and removed all the older docker process before running the docker-compose with with this new image. I have tried clearing the browser cache and it did not help.

Note : When I rollback to the pervious version of 2.1.2-1. I get these errors in the logs now .

Unrecognized field “stream_ids” (class org.graylog2.indexer.ranges.AutoValue_MongoIndexRange), not marked as ignorable (3 known properties: “index_name”, “_id”, “took_ms”])
at [Source: e.undercouch.bson4jackson.io.LittleEndianInputStream@74599b7a; pos: 126] (through reference chain: org.graylog2.indexer.ranges.AutoValue_MongoIndexRange[“stream_ids”])


(Jochen) #4

Are you using any plugins with Graylog? Make sure that they are compatible with Graylog 2.2.x.

Downgrades from Graylog 2.2.x to an older version are not supported.


(Libincheeran) #5

Thank you! the plugins we causing the problem. I uninstalled the plugins and everything works just fine. Appreciate your prompt response and help :slight_smile: