Is this how you upgrade Graylog to 3.2?

I found the following commands to update Graylog to 3.2 (from 3.1) but when I do, it breaks my Search. I have Graylog, Elasticsearch and MongoDB on a CentOS box:

$ sudo rpm -Uvh

$ sudo yum clean all

$ sudo yum install graylog-server

Everything updates like it should but search just says ‘loading…’ at the top. I have tried 3 times and the same thing happens.


Sequence seems correct.
Not clear where do you see “loading…”.
If it’s about browser - try to clean cache

Have you checked this doc?
It contains some other important steps for the upgrade.

I guess that you have not updated the plugins in your environment - check them too if they need to be upgraded.

I tried deleting cache and also tried different browsers. It says loading when I go to the main “search” page at the top next to streams. I’ve heard others say there are a lot of issues with 3.2 and it should have never been released so soon. Is this true?

Are these settings in /etc/graylog/server/server.conf? I don’t see the ones they suggest changing below:


Check the browser developer tools output on the client and graylog log on the server side

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.