Issue with 2.23 to 2.30 Update (Tarball)


(Tim May) #1

Good morning,

This morning I did what I always do when a new update comes out, and for the first time, it broke things. I always hold on to the old one, so I put it back and all is well now, but I thought I’d seek some input.

I run graylog on one Centos7 server, along with mongo, and elasticsearch on a second server.

With the update, pretty much everything was broken. No searches available, no output.

I tried put the log in the text of this post but it has too many characters.

Best regards.


(Jochen) #2

You can use services like https://gist.github.com/ or https://0bin.net/ to share your logs.

Alternatively, try formatting your post correctly: http://commonmark.org/help/

Example:

```
logs
```

(Tim May) #3

Thanks a million.


(Jochen) #4

Graylog is unable to connect to Elasticsearch. Make sure that ES is running and that the Graylog configuration file has the correct connection details in elasticsearch_hosts.


(Tim May) #5

Thanks. Unfortunately the same configuration file is in /etc/graylog/server/server.conf that is in the working 2.2.3. I even copied the old graylogctl but I get the same thing. Not sure what’s going on.

Thanks for your help.


(Jochen) #6

Please read the upgrade notes: http://docs.graylog.org/en/2.3/pages/upgrade/graylog-2.3.html


(Tim May) #7

Thanks a million for your help.


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.