Upgrading Graylog


(Matt) #1

Upgrade of graylog nodes to 2.3 successful. Second problem though. It is connecting to a local instance of elasticsearch on the master graylog node instead of my multinode elasticsearch cluster. No changes in configs. Just an upgrade and restart only. Any reason for this or any way to point graylog back to my correct cluster. Past upgrades have be just upgrade and start. Not sure why this is any different. Any ideas?


Upgrade from 2.2.3 to 2.3
(Pierre-Yves Taczynski) #2

I guess you need the elasticsearch_hosts variable to be set. :wink:

http://docs.graylog.org/en/2.3/pages/upgrade/graylog-2.3.html


(Matt) #3

Thank you for the quick update. I’ll look into this. I’m really looking forward to using the new aggregates plugin :slight_smile:


(Matt) #4

Another followup question. Should I be answering yes or no to the updated config during upgrade? or leaving the current and adding the new “updated” elasticsearch settings myself?


(Pierre-Yves Taczynski) #5

This one I can’t tell, we use docker images to upgrade.


(Matt) #6

I’m just checking on the proposed changes. Looks as though if I accept Yes I’ll get the new configuration options for elasticsearch but will have to completely go back over the config and set back up all my current settings for graylog. Listen URI, ES hosts,mongo uri and all the other tunables. Just wondering what is best practice here or if I should just accept the new version and deal with re-inputting all of my graylog config settings.


(Matt) #7

I tried making the changes that documentation link proposes but I just can’t seem to get anywhere with it. I may have to spin up a lab cluster and play around a bit. Unless anybody has any experience they can lend me for upgrading from 2.2.3 to 2.3 with an elasticsearch cluster ver. 2.4.4.


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.