New to Graylog and receiving error messages


(meg) #1

Could not execute search
There was an error executing your search. Please check your Graylog server logs for more information.

Error Message:
Unable to fulfill search request: cannot GET
Search status code:
500


(Kris) #2

Did you install from the repo? Are you trying to search from the webUI or from the command line?


(Jochen) #3

How did you install Graylog (and which version)?
How did you install Elasticsearch (and which version)?
Are there any error messages in the logs of your Graylog node?

See http://docs.graylog.org/en/2.2/pages/configuration/file_location.html for the correct file locations.


(meg) #4

Yes I installed the repo. I tried to search from the interface.


(meg) #5

I used and OVA image 2.2. I installed Elasticsearch 2.4 on the command line. No their are not any errors.


(Jochen) #6

Elasticsearch and all other dependencies of Graylog are already included in the OVA (virtual machine appliance).

Please describe exactly what you did (including the output of the executed commands).


(meg) #7

Here is the history of commands I executed. I reverted back to basic configuration snapshot in VMware. I used the basic configurations.


(Jochen) #8

It looks like you didn’t run graylog-ctl reconfigure after changing the network configuration of your virtual machine.

Please refer to http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#assign-a-static-ip for further details.


(meg) #9

After running the reconfigure command, are there any other commands that need to be ran order for the server to work? I have already downloaded Nxlog on a windows server and tried to make the interface show the results of the log from that server.


(Jochen) #10

Have you also created an appropriate input in Graylog?

Hint: You can also use the Graylog Collector Sidecar to setup collectors on Windows and Linux machines: http://docs.graylog.org/en/2.2/pages/collector_sidecar.html