What versions of MongoDB does Graylog support?

Just curious, because I’m going over the package installations and I’m seeing that the versions of MongoDB that come packaged with Graylog are vastly different in Ubuntu 16.04 and CentOS7 (2.6.10 and 3.2, respectively). Will Graylog 2.1/2.2 work with MongoDB 3.2 on Ubuntu 16?

Hej Kris,

isn’t the documentation clear on this?


The Version included in Ubuntu 16.04 LTS can be used together with Graylog 2.0.0 and higher

Yes, I saw that. What it doesn’t mention is whether or not higher versions of MongoDB can be used as well. Unless the implication is that only the version packaged in 16.04 can be used.

I am wanting to know if I can just use version 3.2 or 3.4 due to some issues I’m having with mongodb.conf on the older version.

Hej Kris,

you are right, when you look here: http://docs.graylog.org/en/2.2/pages/installation/operating_system_packages.html#prerequisites

it does not explicit say what numbers, but on the CentOS Installation Guide we point out that 3.2 is OK ( http://docs.graylog.org/en/2.2/pages/installation/os/centos.html ) and I have seen 3.4 working also but did not test myself.

It should be no issue - but as I did not test it myself it is not possible for me to say “yes it is fully supported without any risk an issue”

Fair enough. I’ll test it myself at some point this week. I have to do a couple of installations this week, so I’ll give it a shot on one. I just wanted to know if it specifically WOULDN’T work.

If I find out it does work, I’ll let you know and maybe that can be included in the documentation.

Thanks, Jan.