Web Interface Empty Reply (Solved)

I have a brand new installation. Running on CentOS 7.7, Mongo 4.0.2, latest stable graylog. Not using docker of any sort.

Graylog is running on a LAN static, no error messages at all in the logs, so by all standards I would expect to be able to login at http://10.99.X.X/9000

When I attempt to hit that page Chome says “empty response”. If I use cURL I get the same.

curl -v -X GET http://10.99.X.4X:9000
Note: Unnecessary use of -X or --request, GET is already inferred.
*   Trying 10.99.X.X...
* Connected to 10.99.X.X (10.99.X.X) port 9000 (#0)
> GET / HTTP/1.1
> Host: 10.99.X.X:9000
> User-Agent: curl/7.64.1
> Accept: */*
* Empty reply from server
* Connection #0 to host 10.99.X.X left intact
curl: (52) Empty reply from server
* Closing connection 0```

After toiling around and toiling, I finally ran the same CURL command on the box it self and it worked, so I assumed this point it’s a firewall rule. I flushed all firewall rules (had some on here from previous ELK stack) most of which were poorly maintained. I then enabled only http, https, 514 and 9000. Now with fresh firewall rules it appears to be happy as a clam

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.