Can't connect to graylog service


(Phillip Simonds) #1

Hi all!

I’m having issues with the graylog service. I have an nginx proxy sitting in front of graylog. When I navigate to https on my graylog host. I get the response below. If I run a curl from the host the service is running on to https://localhost:9000 I get the same java script as is being passed into my web-browser - so I don’t think the issue is nginx, I think it’s with graylog. I’m not quite sure how to troubleshoot from here. Any help would be great

Message from Graylog

Server currently unavailable

We are experiencing problems connecting to the Graylog server running on . Please verify that the server is healthy and working correctly.

You will be automatically redirected to the previous page once we can connect to the server.

Do you need a hand? We can help you.

Versions

Mongod: v3.6.8
Elasticsearch: 5.6.12
nginx: 1.12.1
graylog: 2.4.6

Warm Regards,

Phillip


(Jan Doberstein) #2

Without knowing your configuration, at least the settings you have used for the res/web part ( http://docs.graylog.org/en/2.4/pages/configuration/server.conf.html#general ) nobody is able to guide you.


(Phillip Simonds) #3

Hi Jan,

Thanks for the reply. I’ve posted my configs below - that is, everything that isn’t commented out.

is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = ### redacted for security
root_username = ### redacted for security
root_password_sha2 = ### Redacted for security
plugin_dir = /usr/share/graylog-server/plugin
rest_listen_uri = http://127.0.0.1:9000/api/
web_listen_uri = http://127.0.0.1:9000/
rotation_strategy = count
elasticsearch_max_docs_per_index = 20000000
elasticsearch_max_number_of_indices = 20
retention_strategy = delete
elasticsearch_shards = 4
elasticsearch_replicas = 0
elasticsearch_index_prefix = graylog
allow_leading_wildcard_searches = false
allow_highlighting = false
elasticsearch_analyzer = standard
output_batch_size = 500
output_flush_interval = 1
output_fault_count_threshold = 5
output_fault_penalty_seconds = 30
processbuffer_processors = 5
outputbuffer_processors = 3
processor_wait_strategy = blocking
ring_size = 65536
inputbuffer_ring_size = 65536
inputbuffer_processors = 2
inputbuffer_wait_strategy = blocking
message_journal_enabled = true
message_journal_dir = /var/lib/graylog-server/journal
lb_recognition_period_seconds = 3
mongodb_uri = mongodb://localhost/graylog
mongodb_max_connections = 1000
mongodb_threads_allowed_to_block_multiplier = 5
content_packs_dir = /usr/share/graylog-server/contentpacks
content_packs_auto_load = grok-patterns.json
proxied_requests_thread_pool_size = 32


(Jan Doberstein) #4

did you use any kind of proxy or did you have graylog running on the computer you are currently using? because you bound the webinterface to localhost …


(Phillip Simonds) #5

Yes sir, using nginx.


(Jan Doberstein) #6

Does your nginx configuration follow: http://docs.graylog.org/en/stable/pages/configuration/web_interface.html#nginx

Keep an eye on X-Graylog-Server-URL as this has to be the hostname/virtualhostname of your nginx.


(Phillip Simonds) #7

Hi Jan,

Ahh - so I used the config from the document, but in my complete newb-ness I left the variables as variables rather than replacing them with their literal values. I replaced $server_name with the actual name of the server and that worked. Thank you so much for your assistance, I really appreciate it.


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.