Stream: Page not Found gorilla

Hello,

I’ve been testing 3.2.1 now that extractors work again :+1:

Noticed that under /streams if i select my <stream name> stream, I get the Page Not Found gorilla.

I thought maybe it had to do because I imported my content pack from 3.1.X, but I created a New stream and still get Page Not Found message.

At least in 3.1.X behavior, after I select the stream, it would take me to the /search page, with that stream as the query.

I have no issues while under /search selecting my stream from the drop down menu. (works as expected)

Is this normal?

Hope it’s clear.

Thank you,
Dave

he @davama

what is the error you see in the Graylog server.log when that happens?

Was that a fresh installation or was that an upgrade at all? What MongoDB Version did you run with? Is that the only not working part?

@jan Thank you for the reply. Apologies, I should have provided that…

mongodb-org-tools-4.0.16-1.el7.x86_64
mongodb-org-server-4.0.16-1.el7.x86_64
mongodb-org-shell-4.0.16-1.el7.x86_64
mongodb-org-4.0.16-1.el7.x86_64
mongodb-org-mongos-4.0.16-1.el7.x86_64
elasticsearch-6.8.6-1.noarch
graylog-3.2-repository-1-1.noarch
graylog-integrations-plugins-3.2.1-1.noarch
graylog-server-3.2.1-1.noarch
graylog-plugin-auth-sso-3.2.1-1.noarch
CentOS Linux release 7.7.1908 (Core) 3.10.0-1062.12.1.el7.x86_64

It was an upgrade from 3.1.X.
I had deleted my mongodb db and started fresh on that end. Removed my content pack and reinstalled. But not beans :frowning_face:

Like i mentioned before, I tried craeting a new stream but still get the Page Not Found.

Logs dont show anything when that Gorilla comes up, just normal stuff:

/var/log/graylog-server/server.log

2020-02-11T16:02:24.157Z INFO  [InputStateListener] Input [Syslog UDP/5e42d00f09ecee03259f9f58] is now RUNNING
2020-02-11T16:02:24.159Z INFO  [InputStateListener] Input [Syslog UDP/5e42d00f09ecee03259f9f74] is now RUNNING

Please let me know if you need more info from me

-Dave

Yes, only not working park that i have discovered as I continue fiddling/testing

he @davama

I can’t imagine a reason for that. What browser did you use? Have you tried a different one?

@jan thank you for the feedback

I have tried Google Chrome, Internet Explorer (though it looks ugly here but Gorilla still shows), Edge

I have clear history on all of them and nothing…

Cant test with firefox at this time…

Here is my nginx if it is relavant:

location /graylog/ {
	#set $upstream_target http://127.0.0.1:9000;
	#proxy_pass $upstream_target;
	#include authelia_config/auth.conf;
	#include authelia_config/proxy.conf;

	proxy_set_header Host $http_host;
	proxy_set_header X-Forwarded-Host $host;
	proxy_set_header X-Forwarded-Server $host;
	proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
	proxy_set_header X-Graylog-Server-URL https://$server_name/graylog/;

	rewrite          ^/graylog/(.*)$  /$1  break;
	proxy_pass       http://127.0.0.1:9000;
}

Created a gif to show; not sure if it’ll work…

graylog-stream-gorilla

Link: https://i.imgur.com/Y75u1r5.gif

@jan

Update:

I believe I found the issue!!

So I created a new graylog instance on a new vm and can confirm that the Gorilla still lives!! :disappointed:
I cannot select a stream.

So on this new instance I moved from a subdirectory in nginx to root / and streams work fine…

Perhaps a bug with using subdirectory?

Thanks,
Dave

he @davama

it could be, you m ight check github if someone already found/reported that issue and if not, createa bug report

Someone created one: https://github.com/Graylog2/graylog2-server/issues/7447

Update:

You can follow this PR which should hopefully solve this issue: