Saving the Time Range in Dasboard does not work

Hello, we are running Graylog 4.1.13+abc344a.

I have created a Dashboard with all my wanted data. Now i want to save the time range into the dashboard.

I view the dashboard as an admin, select the desired time-range with the blue clock icon (12h relative first try, but also predefined 1d on second) and click on apply filter. Works flawlessly.

Now i save the Dashboard. After leaving and returning to the Dashboard page the Time Range defaults again to 5 minutes.

I already read through:

And it really does not work like this. The Time Range always defaults to 5min whenever the Dashboard is opened.
Any help? How to Troubleshoot this? Maybe i could manually edit the config file of the Dashboard?

Case can be closed.

I added the Timerange to every Widget individually and Applied the changes, saved the Dashboard. Simply setting the global timerange didnt work.

You should not need to apply this workaround. The expected behavior is for the global timerange override to persist.

I filed an issue: Dashboard timerange override is lost after save · Issue #12590 · Graylog2/graylog2-server · GitHub

1 Like

If you are building a dashboard with widgets that have different time periods then setting the default behavior of saving the global time period to all widgets would break your intention…

Hi, just for clarification, i encountered the following behavior:

Setting global Timerange in the Dashboard(blue clock button) > Apply filter to all widgets (green button) > Save & Reload = global Timerange 5min again.

Setting (same) Timerange for widgets individually > applying changes to widget > Save & Reload Dashboard = Timerange stays like intended.

Because of the fact i couldnt find anything to this Topic, my best guess was that i encountered an bug. Just wanted to make sure im not missing something obvious.


Seems counter-intuitive to not persist the global timerange, just the widget timeranges.
My expectation is that if I set a global timerange, that’s applied to all widgets; and persists after save. And if I override the global timerange within a widget, then that override should also persist, while all other widgets continue to inherit the global timerange.

Anyway - issue if filed, so we’ll see what the Search Team says.

Looks like it was closed. :frowning:

We can agree to disagree! :smiley: If I have a time in mind as a default I set is as so in the widgets. For instance I have an 8 hour dash for Remote Access. When I change it globally occasionally for 24 hours or 48 I know it will revert back to the 8. Conversely and to your point… if I wanted to change the whole dash to 24 hours I would have to modify each widget… yuk

There’s an argument to be made either way. Maybe there could be a radio button you can select, if you want the global setting to persist.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.