Problem when trying to install on Ubuntu Server with wget package download


(Felix Burs) #1

Hey Guys,
i want to use graylog as Syslog Server on my LibreNMS System. I tried to install Graylog for hours now and i don’t get it running.

My Server is an Ubuntu 18.04.1 LTS and i followed the Dokumentation from http://docs.graylog.org/en/2.5/pages/installation/os/ubuntu.html with apt. Everything is fine until the beginning of the Graylog installation. The very first command wget https://packages.graylog2.org/repo/packages/graylog-2.5-repository_latest.deb let my server freeze when its connecting to the graylog aws servers.

I have no idea what is wrong with this server. Everything else works fine except of this access.

Some ideas how to fix this?


(Jake Smith) #2

Hello Felix,

I just tried it and it worked for me.

Maybe a bit more information about how your network is setup. I have installed it both in ubuntu 16.04 and 18.04 LTS and it worked. Could you have a connectivity issue?

Also install tcpdump and use the -w option to write a pcap file, then open in wireshark might also help.

If you post some more information, people here may be able to help.

Cheers

Jake


(Felix Burs) #3

Hi Jake,
thanks for you reply. The network setup is pretty easy, only one firewall between my server and the internet access. I just add a rule that every traffic from my server to the internet is allowed, just to be sure that nothing is blocked. There is no proxy or something else.

Then I started a packet-capture on my firewall, for the first test this was the easiest way for sniffing, and i got the same error as before. Then i noticed a typo in my ip-address filter. But theb some magic happend and my second try works completely normal. I got the .deb package. Please don’t ask why!
I try it a few times more: 2 times freeze, 1 working access, than again freeze and last time was ok. Something is strange but i habe no idea why this is happening.

I would like to say, that everything is fine now but i got the next problem:
i did dpkg -i graylog-2.5-repository_latest.deb for installing the package but with apt-get install graylog-server (with apt-get update first) i only get: Package not found


(Jan Doberstein) #4

did you refresh the cache (apt-get update) after you have added the repository?


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.