Installation issue: Ubuntu Server locks during installation


(Jesse Kroh) #1

Good morning.

I am trying to setup a new Graylog server. I started with the latest Ubuntu LTS Server build 18.04.

I then followed the installation instructions found here http://docs.graylog.org/en/2.5/pages/installation/os/ubuntu.html

When I run “wget https://packages.graylog2.org/repo/packages/graylog-2.5-repository_latest.deb”, the server will display the following and lock:

Accountname@graylog:~$ wget https://packages.graylog2.org/repo/packages/graylog-2
.5-repository_latest.deb                                                        
--2019-01-03 14:33:37--  https://packages.graylog2.org/repo/packages/graylog-2.5
-repository_latest.deb                                                          
Resolving packages.graylog2.org (packages.graylog2.org)... 34.196.237.103, 35.17
3.6.94, 34.238.3.58, ...                                                        
Connecting to packages.graylog2.org (packages.graylog2.org)|34.196.237.103|:443.
.. connected.                                                                   
HTTP request sent, awaiting response... 302 Found                               
Location: https://graylog2-package-repository.s3.amazonaws.com/packages/graylog-
2.5-repository_latest.deb?AWSAccessKeyId=AKIAIJSI6MCSPXFVDPIA&Expires=1546526618
&Signature=1MBCXh2tHOswT2AjuQrYBqVHflI%3D [following]                           
--2019-01-03 14:33:38--  https://graylog2-package-repository.s3.amazonaws.com/pa
ckages/graylog-2.5-repository_latest.deb?AWSAccessKeyId=AKIAIJSI6MCSPXFVDPIA&Exp
ires=1546526618&Signature=1MBCXh2tHOswT2AjuQrYBqVHflI%3D                        
Resolving graylog2-package-repository.s3.amazonaws.com (graylog2-package-reposit
ory.s3.amazonaws.com)... 52.218.53.17                                           
Connecting to graylog2-package-repository.s3.amazonaws.com (graylog2-package-rep
ository.s3.amazonaws.com)|52.218.53.17|:443... connected.     

The only way to unlock has been to reset power on the server. I tried running the “wget” from an SSH terminal and it locked up the console session as well. Any help or suggestions, would be appreciated.

Other than this hiccup, the installation instructions have been working very well. I am a Windows admin primarily and the last time I seriously played with Linux, Bill Clinton was President.

Thanks so much.


(Tess) #2

The day that a simple “wget” can lock up an entire server seems like a good indication of The End Times™ to me. In the very least it would be a very interesting case study :smiley: Literally the only thing you’re doing, is telling wget to download one single file.

Can you not:

  • Kill the running wget with ^C?
  • Kill the running wget from a second SSH session?

Either way, this is not a problem specific to Graylog as wget is a standard, cross-platform tool. We can certainly try and help you though…

Time for basic troubleshooting!

  • Apparently the naming resolution works just fine, because wget can connect to the web server.
  • Instead of using wget, what happens when you run:
curl -o /tmp/graylog-2.5-repository_latest.deb https://packages.graylog2.org/repo/packages/graylog-2.5-repository_latest.deb

(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.