Nothing related to License appears under System Menu


#1

I’m testing Graylog 2.5.1 on CentOS7, have it running, web page responding normally, no data sources yet defined. I have the following plugins in the plugin folder:
[root@tencen1 plugin]# ls
graylog-plugin-archive-2.5.1.jar graylog-plugin-license-2.5.1.jar
graylog-plugin-auditlog-2.5.1.jar graylog-plugin-map-widget-2.5.1.jar
graylog-plugin-aws-2.5.1.jar graylog-plugin-netflow-2.5.1.jar
graylog-plugin-beats-2.5.1.jar graylog-plugin-pipeline-processor-2.5.1.jar
graylog-plugin-cef-2.5.1.jar graylog-plugin-threatintel-2.5.1.jar
graylog-plugin-collector-2.5.1.jar LICENSE-ENTERPRISE
graylog-plugin-enterprise-integration-2.5.1.jar

I have obtained a 5G enterprise license, but when I login as admin and select System, nothing related to License appears. I’ve restarted all services and the web app is responsive, it just doesn’t have any means to add a license. Is there a known manual method to invoke the add license function manually via URL, or am I missing some dread component ya think? I tried java -jar graylog-plugin-license-2.5.1.jar it just pukes, for want of vital javastuff I guess.

How to license this beast? Any ideas?


#2

Looks like the Universal Cure fixed it, nothing better than a reboot to clear the cobwebs from whacky stacks. License installed without further issue.