How to configure listen on IPV4 and IPV6? Only one of these is working, but not both


(Mario Loderer) #1

Hello all :slight_smile:

the servers interface should be available with ipv4 and ipv6. But it is working with 4 oder 6 but not with both. So what i’am doing wrong?

i’ve set these options in the server.conf:

web_listen_uri = http://fqdn:9000/
rest_listen_uri = http://fqdn:9000/api/
rest_transport_uri = http://fqdn:9000/api/ 

with this it is working with ipv4. Same if i change it to the ipv4 address of the server. If i would like to use ipv6 i have to put the ipv6 address instead of the fqdn or the ipv4 address. After putting the ipv6 address in optionsfields the server is available with the ipv6 address and the fqdn.

So what is to do that the server is available with both ipv6 and ipv4?

Thanks a lot


#2

As far As I know it doesn’t possible.
Try to use nginx/haproxy tó forward IPv6 to v4.


(Mario Loderer) #3

Ah ok. Srange. Hope this will be solved in 3.x.


(Mario Loderer) #4

Is there an howto for? Can’t find usable information about.


#5

I would like to share my best friend’s resources.


(Mario Loderer) #6

:grinning::rofl::rofl: Thank you!


(Jan Doberstein) #7

with this it is working with ipv4. Same if i change it to the ipv4 address of the server. If i would like to use ipv6 i have to put the ipv6 address instead of the fqdn or the ipv4 address. After putting the ipv6 address in optionsfields the server is available with the ipv6 address and the fqdn.

has your client that connects to Graylog ipv6 as prefered connection? In Addition - read the comments above the settings …

http://docs.graylog.org/en/2.5/pages/configuration/server.conf.html#general


(system) closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.