dual stack and graylog WEB interfaces http_bind_address

I have tried to apply both a IPv4 and IPv6 address in the server.conf file.
http_bind_address = IPv4
http_bind_address = IPv6
With sudo lsof -i -P -n | grep LISTEN I can see that only IPv6 ( the last line is used)

How can I config so both addresses are used?

Can you share the 2 line from your server.conf where you are configuring http_bind_address?

I just did some quick testing and here is what i found:

  • Graylog, by default, will listen/accept connections over IPv6
    • For example, i had http_bind_address = but was still able to reach graylog via the server’s IPv6 address
  • The IPv6 equivalent of is [::]
    • Example: http_bind_address = [::]:9000
  • In a web browser (i tested with Google Chrome) the IPv6 address must be enclosed in square brackets [ ].
  • When BOTH IPv4 and IPv6 addresses are configured via http_bind_address, i do only see the IPv6 port via lsof
    • Example: IPv6 45735 0t0 TCP *:9000 (LISTEN)

Hope that helps.

Hi Drew

Thanks for replying.

I just tried it and when I added both IPv4 and IPv6 only IPv6 worked from the browser.

My two lines looks like this. I have masked the two IP number.

http_bind_address = ##.##.##.11:9000 (No response in web browser)

http_bind_address = [fc00:18f:11ab:####:##:##:##:11]:9000 (Works)

If I remove the IPv6 line the IPv4 line starts to work.

I have the following versions installed

graylog-5.1-repository/stable,now 1-2 all [installed]

graylog-server/stable,now 5.1.4-1 amd64 [installed]

mongodb-database-tools/jammy,now 100.7.4 amd64 [installed,upgradable to: 100.7.5]

mongodb-mongosh/jammy,now 1.10.3 amd64 [installed,automatic]

mongodb-org-database-tools-extra/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org-database/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org-mongos/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org-server/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org-shell/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org-tools/jammy,now 6.0.8 amd64 [installed,automatic]

mongodb-org/jammy,now 6.0.8 amd64 [installed]

opensearch/now 2.9.0 amd64 [installed,local]



Just to confirm, you are using Ubuntu Server 22?

Are you able to reach graylog locally on the server via ipv4 when ipv6 is enabled.? e.g.

curl localhost:9000