Ipv6 to Ipv4 help me


(Gianluca) #1

Hi all
i need help to resolve my problem i have graylog version 2.3 on ubuntu 16.04 when i give netstat -lntp:
tcp 0 0 127.0.0.1:27017 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN -
tcp6 0 0 10.53.134.76:9000 :::* LISTEN -
tcp6 0 0 127.0.0.1:9200 :::* LISTEN -
tcp6 0 0 ::1:9200 :::* LISTEN -
tcp6 0 0 :::80 :::* LISTEN -
tcp6 0 0 127.0.0.1:9300 :::* LISTEN -
tcp6 0 0 ::1:9300 :::* LISTEN -
tcp6 0 0 :::22 :::* LISTEN -

listen only on ipv6 how i can listen also in ipv4?
i readed documentation but i don’t know where put this -Djava.net.preferIPv4Stack=true


(Jan Doberstein) #2

@GiangiLuka

did you have issues connecting to IPv4 on this Graylog installation?

If you like to set the value to your startup variables you can find the default file location in the documentation ( http://docs.graylog.org/en/2.3/pages/configuration/file_location.html ) depending on your setup.

regards
Jan


(Gianluca) #3

thanks yes i have problem with IPv4 connecting, i have deb
but i don’t know how to modify can help me Jan?


(Jan Doberstein) #4

Hej @GiangiLuka

you need to modify the file that contains the JVM settings ( http://docs.graylog.org/en/2.3/pages/configuration/file_location.html#graylog ) and add the setting to GRAYLOG_SERVER_JAVA_OPTS.


(Gianluca) #5

Thanks jan
I solved i modified not only graylog file but also on elasticsearch.


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.