Graylog + Haproxy + Nginx


I installed the following packages:

Graylog 4.x
ElasticSearch-Oss 7.10.x
MongoDB 4.0
Java 11.x

I have the following issues:

I tried to run an HAPROXY to pass the access via WEB but i always keep “net::ERR_CONNECTION_REFUSED” from the browser console.

I tried to config my HAPROXY with the following help: Web interface — Graylog 4.0.0 documentation

But it gives me the same error. The domain doesnt exist, just is configured in my host.conf file.

When i test the access of the Graylog Web Panel via NGINX it works.

Could somebody help me or maybe have the same problem?

Best Regards

Hello, Bokudan,

I noticed that your post hasn’t been responded to yet. Can you send me your configuration file privately? Your question is important to the community. I’ll help you find the right person and possible solution with a bit more information on your end.

Here’s a checklist of things to ensure when configuring your browser. You may have already done these things. If so, please let me know.

  • The HTTP port of the load balancer/reverse proxy is accessible for clients
  • The HTTP address for the Graylog server is properly set (as explained in How does the web interface connect to the Graylog server?), so it is resolvable and accessible for the load balancer/reverse proxy.
  • If you use SSL, your certificates must be valid and trusted by your clients.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.