Graylog web interface connection refused error

Hi all,

Have been trying to setup a simple graylog setup in AWS Docker Swarm but to no avail.

Am constantly getting a “Err_Connection_Refused” from http:<my_aws_lb_endpoint>:9000

Any advice will be greatly appreciated.

below is my docker-compose file

version: '3.4'

services:
  mongo:
    image: mongo:3
    volumes:
      - mongo_store:/data/db
    networks:
     - graylog_network

  graylog:
    image: graylog/graylog:3.1
    environment:
      # CHANGE ME (must be at least 16 characters)!
      - GRAYLOG_PASSWORD_SECRET=somepasswordpepper
      # Password: admin
      - GRAYLOG_ROOT_PASSWORD_SHA2=8c6976e5b5410415bde908bd4dee15dfb167a9c873fc4bb8a81f6f2ab448a918
      - GRAYLOG_HTTP_BIND_ADDRESS=0.0.0.0:9000
      # Elastic Settings
      - GRAYLOG_ELASTICSEARCH_HOSTS=https://<my_aws_elasticsearch_service>.es.amazonaws.com/
      #- GRAYLOG_ELASTICSEARCH_COMPRESSION_ENABLED=true
    depends_on:
      - mongo
    networks:
     - graylog_network
    ports:
      # Graylog web interface and REST API
      - 9000:9000
      # Syslog TCP
      - 1514:1514
      # Syslog UDP
      - 1514:1514/udp
      # GELF TCP
      - 12201:12201
      # GELF UDP
      - 12201:12201/udp

volumes:
  graylog_journal:
    external: true

networks:
  mongo_store:
    external: true
1 Like

he @gang89

do you have any http_external_uri settings somewhere not visible in the configuration? What is your Loadbalancer configuration?

1 Like

Hi @jan,

Thanks for getting back.

I tried adding the below condition with multiple uri combination

  • private IP of EC2
  • public IP of EC2
  • Load Balancer IP

But doesnt work as well.

The load balancer configuration is out of the box from docker for AWS configuration. In the event a service is running in docker swarm, it will automatically discover the service and expose the port to the internet. However I see that for graylog, somehow it does not expose port 9000.

- GRAYLOG_HTTP_EXTERNAL_URI=http://<uri>:9000/
1 Like

you should carefully read what the settings are for …

the http_external_uri needs to the the URI where your Browser is able to reach Graylog.

Please read carefully about the different settings: https://docs.graylog.org/en/3.1/pages/configuration/server.conf.html#web-rest-api

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.