Dont show russian characters

Problem: when sending data to Graylog, encoding conversion problems are observed:
if the text with numbers contains Russian characters, the search for such a message does not work.

Example:
EC111115377
GrayLog shows: \ xC111115377

@jan, can u help me please? its really important task for me

I don’t see any russian character in your example, please post real example…

letter “E” is on russian.

please send exact unicode code for E in russian

i think is this?

0415

I tried send same message with logger from linux (with UTF-8 support) and it worked correctly for me:
logger $(printf '\u0415C111115377')

I can correctly see ЕC111115377 in graylog web, and can find it with no problem…

Which protocol do you use to transfer log? syslog/gelf/beat? What is your source which send this message? If linux check if you have setup correct locale, output of command locale should be UTF-8, for example ru_RU.UTF-8

I use on the server where the nginx logs come from, then the messages go to the local syslog, after they are redirected to the syslog in graylog, and from there they get into graylog

i sen what u say and graylog give me this:

But when I type russian “E” and send, then show me this:

can u help me please?

I want to get an answer