Dashboard refresh on api call failure

1. Describe your incident:
Dashboard with additional search fields reloads the default dashboard after API update failure. The following error message is displayed on the First API failure then is replaced by the “default” dashboard on the next good API call.

This happens somewhat regularly and causes the dashboard to go back to the default dashboard which is inconvenient when researching something.

This only happens on remote clients which are over a WAN. Clients that are on the same internal subnet do not experience this since it seems the API calls do not fail on the LAN.

Note: the API failure I’m talking about is the failure of the API calls that show the messages being processed at the top of the Graylog banner. Nothing else is happening on the screen when the above message appears.

2. Describe your environment:

  • OS Information: Client browser (Firefox, latest), Windows 10 desktop.
  • Server Information: Graylog 5.2.7, containers in Kubernetes (7 nodes).

3. What steps have you already taken to try and solve the problem?

Nothing. I don’t know what to do other than try and make the WAN more stable but that is difficult.

To reproduce the issue here are the steps in Firefox. I assume it works in Chrome as well:

  • Create a dashboard and save it.
  • Open dashboard and add an additional search criteria or change the time period.
  • Let the dashboard load completely
  • In the Firefox debug window (F12) under network change the throttling selection from “No Throttling” to “Offline”.
  • Page will display error message or one similar to the one shown above.
  • Wait a few seconds then change it back to “No Throttling”.
  • Dashboard will completely reload back to “original” settings" without the added search or time period criteria.

4. How can the community help?

Is there a way I can disable the “helpful” message processing display so that the API calls don’t fail and cause the page to reload? I have checked all of the documentation and I can’t find anything.