Collector Sidecar Tags issue


(Robp1234) #1

Hello

Struggling to get Collector Sidecar up and running. In
/var/log/graylog/collector-sidecar/collector_sidecar.log

I see:

time=“2018-07-04T17:06:03Z” level=info msg="[RequestConfiguration] No configuration found for configured tags!"

My c-s config is:

23

You can see I have created two tags; dropbox and robtest (I’m not imaginative)

I can see in the Graylog interface that the comms are working as the tags are appearing:

11

However, as can be seen from that screenshot, the configurations are not found (to be expected for robtest but I have created one for dropbox).

I think I have a problem somewhere which is preventing the tagging working properly when I created configurations. As can be seen is this screenshot there are no tags in the drop down menu, nor do any appear when I type:

I think this means the configurations I am created for Dropbox are not getting tagged as such, and hence the problems with collector-sidecar.

Edited to add:

Graylog 2.4.5, sidecar-collector 0.1.6

Thoughts, obvious errors etc welcome.

thanks

Rob


(Jan Doberstein) #2

you should re-read the step-by-step guide of the documentation.

The tags you create in at the sidecar server will not appear at the Graylog GUI - you need to create them in Graylog too and that creates the connection between the configuration and the client.


(Robp1234) #3

Hi,

I have followed the step by step guide twice now, and it does not work for me. I do not seem to be able to create tags. I have created configurations, and tried to tag them dropbox, but I think it is that that is not working. I just get the same error in the sidecar log file about No configuration found.

You can see from this screenshot no tags have been applied, despite me typing ‘dropbox’ into the tag field and hitting update tags (and trying various other things too)

04

This is the Tags box - nothing appears in the drop down, and I have tried creating new ones by typing the name with no results.

Rob


(Robp1234) #4

Ok, I figured it out. GUI misunderstanding - you need to hit enter, and not update tags to apply a new tag!

Rob