Change graylog Logo


(john) #1

Hi,

Is it possible to change graylog logo?

Thanks,
Grayuser


(Jochen) #2

No, not out of the box.

You would need to build your own Graylog artifact from source to change the logo.

If you’re brave and know what you’re doing, you could also modify the existing Graylog artifact (JAR file) and replace the included image file.


(john) #3

Hi,

  1. Could you explain how to build Graylog artifact?
  2. Where can I find the existing Graylog artifact?

Thanks,
Grayuser


(Jochen) #4

Take a look at the Graylog2/graylog2-server repository and the included Travis CI configuration.

It’s the graylog.jar file included in your Graylog installation.


#5

@john If you would like to change the graylog logo for the most stable version of graylog follow these steps.

  1. git clone https://github.com/Graylog2/graylog2-server.git
  2. git checkout -b 2.3.1 2.3.1
  3. Change the logo file in graylog2-web-interface/public/images/topologo.png to your desired image (make sure you leave the name the same)
  4. Run mvn install at the root of the graylog2 -server repo
  5. run mvn assembly:single
  6. Navigate to graylog2-server/target/ and there you should find a TAR ball.
  7. Extract the tarball and you should have a graylog.jar
  8. Replace what ever graylog server jar with your new custom jar (ensure permissions stay the same and ownership, you might have to chown the custom jar once it is on your server.

(brian) #6

Hello, I noticed that you have built the project yourself, can you tell me the environment you use?
I followed your steps, but when I use mvn install to build the project.


#7

@brian what happens when you run mvn install? Also I am building graylog on a Mac.


(brian) #8

It failed. I download the whole github 2.3.1 then run mvn install, it fails. Seems that I need to run git at first?


(brian) #9

By the way, do you have some pre configuration?


#10

What do you mean by pre-configuration? Also does the build fail or do you just see those errors!? Those errors you showed me are normal.


#11

I would also recommend having git installed if you don’t. And cloning the repo like I stated in my steps. Not downloading a zip file of the server.


(brian) #12

I installed git and when i use git checkout tag/2.3.1 it tells me that no such tag… So I have to download the zip file to build~
Thanks very much, i found ‘Request help for the contribution documentation’ this page, it said that if i run as a root, during the build period i shall incur these errors. I run as a normal user now, and mvn install takes a lot of time, hope it will be OK. I want to do some L10N and change the logos~ Thanks very much, I will update if the result come out~


#13

@brian The only pre-configuration I have done is installed git, maven, and java.


#14

@brian Running git checkout -b 2.3.1 2.3.1 should create a branch and checkout version 2.3.1


(brian) #15

Succeed, however, there are some test cases failure, and and if i skipped test, it can build and assembly~


(system) #16

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.