Cannot find configuration file for email


(meg) #1

Receiving error: The configuration for the email transport subsystem has shown to be missing or invalid. Please check the related section of your Graylog server configuration file. This is the detailed error message: Email transport is not enabled in server configuration file!

Trying to access the configuration file, however I am having a hard time and when I try to access the file with the command nano /etc/graylog2.conf there is no file to modify.


(Jan Doberstein) #2

hej @flowersme

what flavor of Graylog you are using? our documentation should guide you


(Jan Doberstein) #4

did you check if the OVA is able to connect to the Mailsystem?

It looks not like. Running the OVA you need to use the graylog-ctl script to configure mail.


(meg) #5

I have used the graylog-ctl script SMTP configure emails and it still has yet to worked and is throwing me an error.


(Jan Doberstein) #6

hej @flowersme

if you post the error - and/or some loglines from your graylog server.log we might help you.

/jd


(meg) #7

Here is an example of the error that I am receiving.


(meg) #8


(Philipp Ruland) #9

Hey @flowersme,

you got an UnknownHostException. So check if the domain you configured is correct and resolvable by the Graylog instance. Example:

[user@server ~]$ host mailserver.myhost.local

You should get something like

mailserver.myhost.local has address x.x.x.x

Greetings - Phil


(meg) #10


(Jan Doberstein) #11

you are missing some essential settings … please read the documentation and move on: http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#configuration-commands

sudo graylog-ctl set-email-config
<smtp server> [--port=<smtp port>
--user=<username>
--password=<password>
--from-email=<sender-address>
--web-url=<graylog web-interface url>
--no-tls --no-ssl]

(meg) #12

I have used the email config commands this is the error I am receiving after entering the commands


(Jochen) #13

Is your SMTP server listening on the given address (the <smtp server> part in the set-email-config command) on port 587 (the <smtp port> part in the set-email-config command)?