Graylog OVA Sending Email Alerts


I am new to Graylog and I apologize in advance if this is a silly question.

I want to setup email alerts using the OVA I downloaded from However, I am unable to do so as I keep encountering the SMTP error. I tried updating the config settings using the graylog-ctl and the graylog-settings.json file in /etc/graylog/ directory… I’ve tried looking up for a possible solution but I haven’t been successful so far. Please let me know if I can do this, if yes can someone post a working example?

Thank you for your help



  • what exactly have you done
  • what exact message you received as an error
  • what is your wanted scenario that should work


I downloaded the OVA image Graylog-2.3.2.ova on my local system and I’m using VirtualBox to run it. I have updated the graylog-settings.json file in /etc/graylog directory to this -

  "smtp_user": "abc@xyz",
  "internal_logging": true,
  "web_listen_uri": false,
  "web_endpoint_uri": false,
  "rest_listen_uri": false,
  "rest_transport_uri": false,
  "external_rest_uri": false,
  "custom_attributes": {

When I try sending a test email alert I get this error -
Sending test alert notification failed with message: Sending the email to the following server failed:

I am trying to configure the email alerts to be sent from "" to my personal email id.

Please let me know if you have any other questions



did you run graylog-ctl reconfigure after your changes?


Yeah. I got the error when I hit the test button on the Manage Notifications section.

  1. Your JSON file is syntactically incorrect. There’s a stray double quote next to the smtp_no_ssl key.
  2. What’s in the logs of your Graylog node?
  3. requires SSL on port 465 (see for details).
1 Like

Hi @jochen

Thanks for pointing that out. It worked.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.