Alarm callback has email recipients and is triggered, but email transport is not configured


(Felipe Volpato) #1

Hi!

(Note: I had to suppress links, e-mails, etc… forum’s new user rule)

I am using the OVA Graylog v2.4.6+ceaa7e4 and having issues to enable the feature of send email notifications. I’ve already rebooted and restarted the vm many times. I’ve already run the script:

sudo graylog-ctl set-email-config smtp gmail com --port=465 --user=noreply@luzerna.ifc.edu.br --password=xxxxx --from-email=noreply@luzerna.ifc.edu.br

My /etc/graylog/graylog-settings.json shows:

{
“timezone”: “Etc/UTC”,
“smtp_server”: “smtp gmail com”,
“smtp_port”: 465,
“smtp_user”: “noreply@.luzerna.ifc.edu.br”,
“smtp_password”: “xxxxx”,
“smtp_from_email”: “noreply.@.luzerna.ifc.edu.br”,
“smtp_no_tls”: false,
“smtp_no_ssl”: false,
“master_node”: “127.0.0.1”,
“local_connect”: false,
“current_address”: “172.16.70.98”,
“last_address”: “172.16.70.98”,
“enforce_ssl”: true,
“journal_size”: 1,
“node_id”: false,
“internal_logging”: false,
“web_listen_uri”: false,
“web_endpoint_uri”: false,
“rest_listen_uri”: false,
“rest_transport_uri”: false,
“external_rest_uri”: false,
“custom_attributes”: {
}
}

I am also able to access gmail smtp’s on port 465

Nmap scan report for smtp gmail com (64.233.186.108)
Host is up (0.064s latency).
Other addresses for smtp gmail com (not scanned): 64.233.186.109
rDNS record for 64.233.186.108: cb-in-f108.1e100.net
PORT STATE SERVICE
465/tcp open smtps

Log (/var/log/graylog/server/current) :

WARN [EmailAlarmCallback] Alarm callback has email recipients and is triggered, but email transport is not configured.
WARN [EmailAlarmCallback] Alarm callback has email recipients and is triggered, but email transport is not configured.

There is no traffic from graylog to gmail … am I forgetting something?


(Felipe Volpato) #2

Also… in the graylog web interface… on clicking “test”

Could not send test alert notification

Sending test alert notification failed with message: Email transport is not enabled in server configuration file!


(Jan Doberstein) #3

try the search in this community it is asked and answered many time…


(Felipe Volpato) #4

@jan thank you for your response but I already did it.

Is any configuration left for the OVA version? I saw that for the normal graylog version we need to set this

#Email transport
transport_email_enabled = true


(Felipe Volpato) #5

Finally I found a solution.

I had to configure the /opt/graylog/conf/graylog.conf with the following configuration:

#Email transport
transport_email_enabled = true
transport_email_hostname = smtp.gmail.com
transport_email_port = 465
transport_email_use_auth = true
transport_email_use_tls = true
transport_email_use_ssl = true
transport_email_auth_username = noreply@luzerna.ifc.edu.br
transport_email_auth_password = B4ydsfasdfasdfZBp
transport_email_subject_prefix = [graylog]
transport_email_from_email = noreply@luzerna.ifc.edu.br
transport_email_web_interface_url =

unfortunately, and I do not know why, the script graylog-ctl set-email-config that some users suggest did not work for me . Even with the OVA version.


(Jan Doberstein) #6

if you modify the file /opt/graylog/conf/graylog.conf the changes you have done will be lost on next graylog-ctl run … just to have it written once.


(Felipe Volpato) #7

Actually, it didn’t.


(system) #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.