SMTP server not triggering alert email


(saurabh jaiswal) #1

Hello ,
I am using below email settings on graylog server.conf file
but when I m triggering the test email from graylog server but I m getting an error unable to send mail from
orch-gl-server-dev-1.internal.orch.com server,
but individual I tried to send mail using the same smtp server, I m able trigger mails,
please let me know if am missing something.

Server.conf

# Email transport
transport_email_enabled = true
transport_email_protocol = smtp
transport_email_hostname = orch-gl-server-dev-1.internal.orch.com
#transport_email_hostname = localhost
transport_email_port = 25
transport_email_use_auth = false
transport_email_use_tls = false
transport_email_auth_username = you@example.com
transport_email_auth_password = secret
transport_email_subject_prefix = [graylog2]
transport_email_from_email = saurabh.jaiswal37@gmail.com
transport_email_from_name = Graylog2
transport_email_web_interface_url = http://orch-gl-server-dev-elb-2046488922.ap-southeast-1.elb.amazonaws.com/

(Jochen) #2

What’s the exact error message?


(saurabh jaiswal) #4

Could not send test alert notification
Sending test alert notification failed with message: Email transport is not enabled in server configuration file!


(Jochen) #5

Have you restarted Graylog after enabling the SMTP transport in the configuration file?


(saurabh jaiswal) #7

Yes I restarted graylog server, ( sudo service graylog-server restart)
also I tried with gmail smtp with port 465 in both cases same error
first I click I got : email transport is not enable
second time click again I got error : not able to send mail from this

I got notification created for alert based on rule perfectly fine

plz let me know if u need more details, any help would be grateful to you

output of listener command on graylog server as below

root@orch-gl-server-dev-1:/etc/graylog/server# sudo lsof -iTCP -sTCP:LISTEN -P
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
sshd 1003 root 3u IPv4 14075 0t0 TCP *:22 (LISTEN)
sshd 1003 root 4u IPv6 14077 0t0 TCP *:22 (LISTEN)
master 10292 root 12u IPv4 11809047 0t0 TCP localhost:25 (LISTEN)
java 12016 graylog 55u IPv6 11858931 0t0 TCP *:9000 (LISTEN)
java 12016 graylog 131u IPv6 11860617 0t0 TCP *:5044 (LISTEN)
java 12016 graylog 132u IPv6 11861004 0t0 TCP *:5042 (LISTEN)
java 12016 graylog 134u IPv6 11861006 0t0 TCP *:8515 (LISTEN)
java 12016 graylog 135u IPv6 11861007 0t0 TCP *:12201 (LISTEN)


(Jochen) #8

If you changed the settings in the correct configuration file, restarted Graylog, and the SMTP server is reachable from the machine running Graylog, email alerts should work.

Make sure you edited the correct file and restarted the correct Graylog node.

http://docs.graylog.org/en/2.3/pages/streams/alerts.html#email-alert-notification
http://docs.graylog.org/en/2.3/pages/configuration/file_location.html


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.