Graylog 2.2.3 failed to send email notifaction


#1

I deploy newest 2.2.3 version with OVF but it failed to send test alert notification
Here’s the configuration file I modified. The graylog 2.2.3 is deployed by using OVF.

root@graylog:~# cat /etc/graylog/graylog-settings.json
{
"timezone": "Etc/UTC",
"smtp_server": "10.119.13.185",
"smtp_port": 25,
"smtp_user": "#####@activenetwork.com",
"smtp_password": "secret",
"smtp_from_email": "#####@activenetwork.com",
"smtp_web_url": "http://10.148.10.###/",
"smtp_no_tls": false,
"smtp_no_ssl": true,
"master_node": "10.148.10.###",
"local_connect": false,
"current_address": "10.148.10.###",
"last_address": "10.148.10.###",
"enforce_ssl": false,
"journal_size": 1,
"node_id": false,
"internal_logging": true,
"web_listen_uri": false,
"web_endpoint_uri": false,
"rest_listen_uri": false,
"rest_transport_uri": false,
"external_rest_uri": false,
"custom_attributes": {

}
}


(Jochen) #2

Make sure that 10.119.13.185 is reachable from the virtual machine running Graylog.

What’s the output of the following command:

echo QUIT | nc 10.119.13.185 25

Other than that, check the logs of your Graylog node: http://docs.graylog.org/en/2.2/pages/configuration/file_location.html#omnibus-package


#3

Thanks a lot! I get it! it’s going well after changing the configuration file. it rocks~~


#4

I have another issue when editing configuration file /opt/graylog/conf/graylog.conf. these three configurations will be overwritten every time after run “graylog-ctl reconfigure”. How can I avoid it? I can’t make this modification of true – false successfully.
Thanks a lot!

transport_email_use_auth = true
transport_email_use_tls = true
transport_email_use_ssl = true


(Jochen) #5

You can’t. The OVA and graylog-ctl is supposed to recreate the configuration for all necessary components from the template. It isn’t supposed to support every configuration setting of Graylog.

If you want to customize Graylog completely, you’ll need to set it up yourself and not use the OVA and graylog-ctl.

This being said, take a look at the documentation for graylog-ctl for the correct parameters: http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html#configuration-commands


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.