Email transport is not enabled in server configuration file

I am setting up an new installer for Graylog and for some reason the I keep getting the error “Email transport is not configured in graylog.conf”
Here is the docker-compose setup that I am using GitHub - lawrencesystems/graylog: Graylog 5 setup
My process is:

  • git clone it to an fresh Ubuntu 22.04 running docker
  • set password and TZ data in docker-compose.yml
  • Make needed changes such as email settings to config/graylog/graylog.conf
  • run docker-compose up -d
    Graylog Starts fine, inputs work, log data ingresses fine, but when I try to create email notifications I get that notification that it’s not in the server config.

I used docker exec -it graylog bash to look in the container and confirm the config/graylog.conf within it has the same and what appear to be correct parameters for email in it. I am using the same settings as are in my working (non-docker version) Graylog 4. The only differences I see based on the Graylog Documentation are these setting which are not in my Gralog 4 seutp:

transport_email_use_tls = true
transport_email_use_ssl = false

I have tried it with and without those settings and I feel like I am missing something really obvious here.

I also tested Slack Notifications and they work fine so I know the system can get out to the internet.

Hey @lawrencesystems

Perhaps try this in your docker-compose.

      - GRAYLOG_TRANSPORT_FROM_EMAIL=root@localhost
1 Like

Thanks! That has fixed the issue, but before I mark this as solved, is there any reason it should not work in the graylog.conf file?

Hey @lawrencesystems

Yes it can work with your config file, that was just the easy way.

For the graylog config file you can do two ways.

This will is more perment way

   - ./graylog/config:/usr/share/graylog/data/config

Second, Not preferred in Production Env.

  • Find Graylog container ID.

root # docker ps

  • Locate graylgo config file

root# locate graylog.conf

  • Adjust config file.

root # docker exec -it <container_id> /bin/bash

Just restart GL container, should be good

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.