Broken following 3.0 upgrade

(Phil) #1

Hi All,

Was hoping somebody could help me please, i have just update from 2.4 - 3.0 and following a reboot i cant get back on the web interface. Ive tried multiple restarts and had a look at the logs but im rather new to Graylog so nothing stands out. Would somebody mind just having a look at my log please

2019-03-12T12:20:39.089Z INFO [CmdLineTool] Loaded plugin: AWS plugins 3.0.0 [org.graylog.aws.AWSPlugin]
2019-03-12T12:20:39.093Z INFO [CmdLineTool] Loaded plugin: Collector 3.0.0 [org.graylog.plugins.collector.CollectorPlugin]
2019-03-12T12:20:39.094Z INFO [CmdLineTool] Loaded plugin: Graylog Enterprise 3.0.0 [org.graylog.plugins.enterprise.EnterprisePlugin]
2019-03-12T12:20:39.095Z INFO [CmdLineTool] Loaded plugin: Threat Intelligence Plugin 3.0.0 [org.graylog.plugins.threatintel.ThreatIntelPlugin]
2019-03-12T12:20:39.139Z ERROR [CmdLineTool] Invalid configuration
com.github.joschi.jadconfig.ValidationException: java.lang.IllegalArgumentException: Possible bracketless IPv6 literal: http://logging.vstrading.co.uk:9000
at org.graylog2.configuration.HttpConfiguration.validateHttpBindAddress(HttpConfiguration.java:227) ~[graylog.jar:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_191]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_191]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_191]
at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_191]
at com.github.joschi.jadconfig.ReflectionUtils.invokeMethodsWithAnnotation(ReflectionUtils.java:53) ~[graylog.jar:?]
at com.github.joschi.jadconfig.JadConfig.invokeValidatorMethods(JadConfig.java:221) ~[graylog.jar:?]
at com.github.joschi.jadconfig.JadConfig.process(JadConfig.java:100) ~[graylog.jar:?]
at org.graylog2.bootstrap.CmdLineTool.processConfiguration(CmdLineTool.java:351) [graylog.jar:?]
at org.graylog2.bootstrap.CmdLineTool.readConfiguration(CmdLineTool.java:344) [graylog.jar:?]
at org.graylog2.bootstrap.CmdLineTool.run(CmdLineTool.java:178) [graylog.jar:?]
at org.graylog2.bootstrap.Main.main(Main.java:50) [graylog.jar:?]
Caused by: java.lang.IllegalArgumentException: Possible bracketless IPv6 literal: http://logging.vstrading.co.uk:9000
at com.google.common.base.Preconditions.checkArgument(Preconditions.java:216) ~[graylog.jar:?]
at com.google.common.net.HostAndPort.requireBracketsForIPv6(HostAndPort.java:275) ~[graylog.jar:?]
at org.graylog2.configuration.HttpConfiguration.getHttpBindAddress(HttpConfiguration.java:88) ~[graylog.jar:?]
at org.graylog2.configuration.HttpConfiguration.validateHttpBindAddress(HttpConfiguration.java:222) ~[graylog.jar:?]

Much Appreciated.

(Jan Doberstein) #2

you did not make the needed changes to your server.conf according to the upgrade documentation:

http://docs.graylog.org/en/3.0/pages/upgrade/graylog-3.0.html

please read the above an change your configuration.

(Dale Unwin) #3

Just to add from a user point of view who has managed to successfully upgrade to 3.0, I found that it would only work properly after the upgrade if I chose to replace the server.conf file with the new one, rather than keeping the old one. As Jan points out above the server.conf file has a number of different headings and names for things which is probably why yours hasn’t worked.

(Phil) #4

Hi Jan,

Thanks for your reply, i appreciate the documentation is there for the upgrade but i personally find it extremerly complicated to digest, you say change the configuration but the link you point to just details the changes from the old server.conf to the new, are we to remove the settings, or is it we change the headings of the changes?

It would be helpful if there was some sort of details step by step guide as to what actually needs amending, this is obviously a major update which breaks a number of things, so just to detail changes i personally think isnt enough.

Thanks

(Phil) #5

Thanks Daleish, so did you copy the server.conf from the github page and just paste it into you existing conf, did you then have to amend the new settings with how it was prior?

Any help would be much appreciated.

Phil

(Dale Unwin) #6

When I installed mine, during the installation it said something like “the server.conf file for this update is different to your current server.conf file, do you want to replace it or keep the current one”. I replaced it, and then manually entered all of the same IP addresses and made sure the configurations were the same as my old server.conf file but obviously with the different names. The link that Jan provided has a table which shows which names/settings have been renamed or removed.

(Phil) #7

Many thanks, so you basically extracted the information out your old config file and input it into your new file cross referencing the changes detailed in the link Jan provided?

Ill give that a try, many thanks for your help.

(Dale Unwin) #8

Yep exactly that. Just double check the documentation that there isn’t anything additional that you need to fill in, but I don’t think there was for me.

(system) closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.