Graylog 3.0 Upgrade from 2.5


(Dale Unwin) #1

Has anyone successfully upgraded their Graylog from 2.5.x to 3.0?

Mine seems to go really smoothly every time I try apart from the web interface. This doesn’t load and refuses to connect after the 3.0 update. I’ve read all the release notes and documentation and am aware of the changes to the server.conf file. I’ve added my server’s IP address in the appropriate places in the server.conf file but it just won’t load.

Anyone else had this issue or can shed some light on where I’m going wrong?


(Jan Doberstein) #2

did you upgrade and check all installed plugins? They might broke the setup - in addition did you hard reload (shift +f5) the page?

What error did you get? What is your problem? Please try to not say “my car is broken” but describe more what is the error for someone that is not you or has access to your environment.


(Dale Unwin) #3

I just get a ‘10.x.x.x refused to connect’ in my web browser. I’ve not encountered any errors or issues during the upgrade at all.

In /var/log/graylog-server/server.log I’m getting an error about password_secret being blank, but it’s definitely not. EDIT - this IS blank, I’d only filled in the root_password_sha2.

I’ve just done a netstat and noticed the server isn’t listening on port 9000, is there something that needs enabling somewhere in the conf file?

EDIT Again. Now in server.log I’m getting an invalid configuration - Possible bracketless IPv6 literal: http://10.x.x.x:9000/api


(Dale Unwin) #4

It’s ok, I got it working.

For future reference, the bracketless error was caused by me putting http:// in front of the http_bind_address in the server.conf file. I got another error also after this by putting /api after it.

The correct format for http_bind_address appears to be: 10.x.x.x:9000 only.


(Tess) #5

Two thumbs up for actually sharing the cause and the resolution!

:+1: :+1:


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.