Graylog 3.0 behind proxy (apache with sub dir)

Hi all, this is actually my first post to the community.

I just upgraded from 2.5 to 3.0. Everything is working fine, for the most part.

My problem is that when putting graylog behind my proxy, everything under the ‘system’ menu is broken. An extra ‘/graylog’ is being added to the URL, which gives me the gorilla page. All other pages, dashboards, etc are fine.

I’m using Apache as my proxy. Here is the relevent configuration:

<Location /graylog>
    RequestHeader set X-Graylog-Server-URL "https://$public/graylog/"
    ProxyPass http://$private:9000
    ProxyPassReverse http://$private:9000

For example: https://$public/graylog/system/overview gets set to https://$public/graylog/graylog/system/overview

I could rewrite things, but I think this is a problem with graylog itself. Everything was working properly with the 2.5 version.

Did you adjust the various URI settings in the server config file?

The split URIs for the API and Graylog were replaced, with one single config line. Both older config settings must be removed.

As per here ->

Yes. Without having those right, nothing would work :slight_smile:

Well, without having the one right, nothing would work. But I can imagine having the other stay in place could double up on the “graylog” part of the URI. :slight_smile:

Glad that you thought of this though. Good on you.

The only weird breakage was some dashboard elements I had that used (this that) in queries. Apparently implicit ‘OR’ is gone now? But I digress. I’ll check things again, but it’s only the entire ‘system’ menu that is not working behind a proxy. Everything else is fine.

Seems I’m not the only one with this problem:

1 Like

Good find! Let’s continue in that thread on Github instead.

Unfortunately the issue has been closed. Another person posted the same problem. This definitely seems to be a graylog issue, and not the proxy. See

I have created one github issue for that now:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.