Attaching Graylog Open Source OVA to VM vSphere Client 6.7


#1

I’m having difficulty in Deploying GrayLog 2.5 OVA on VM vSphere Client 6.7 but I’m receiving an error message :48 7 value_illegal value piix4 of resourcesubtype element not found in 6.7.0.
I’ve attempted to follow some of the guides such as :

but the error still comes up.

Ive already tried this https://nolabnoparty.com/en/vmware-fix-invalid-ovf-manifest-entry-error/


(Jan Doberstein) #2

please search the community for the solution to this issue.


(Tess) #3

Yup, this issue has been discussed a few times already.

It’s not a bug introduced by the Graylog developers, it’s not even a bug. The issue is that when they created the OVA they made certain choises for virtual hardware, which your own ESX does not provide. So you’ll have to manually tweak the OVA config, to match your ESX environment.

  • What specifically did you try from this post?
  • Did it fail? If so, with which symptoms?

#4

I’ve tried to extract the files from OVA package via 7-Zip and then re-created the package via VMware OVF Tool the applied the fix “Graylog OVA import problems
but still getting
Issues detected with selected template. Details: - 48:10:VALUE_ILLEGAL: Value ‘‘lsilogic’’ of ResourceSubType element not found in . - 57:10:VALUE_ILLEGAL: Value ‘‘lsilogic’’ of ResourceSubType element not found in . - 66:10:VALUE_ILLEGAL: Value ‘‘3’’ of Parent element does not refer to a ref of type DiskControllerReference.


#5
0 SCSIController SCSI Controller SCSIController 3 lsilogic 5 1 SCSIController SCSI Controller SCSIController 4 lsilogic 5

(Jan Doberstein) #6

we work on the images and changed some settings for future versions.

@Totally_Not_A_Robot see the last commits in https://github.com/Graylog2/graylog2-images/commits/3.0


#7

Just a update i finally got it working.
Thanks guys.
I followed the advice from > “Graylog OVA import problems<
It worked.


#8

For the future
A single one node graylog install not more than 2 hours. With os install, fix Ip setting, etc. Maybe faster than play with ova import.
//I also use ova, it could be fast for a test, but if you have problem, drop out, and try other way.

http://docs.graylog.org/en/2.5/pages/installation.html


(system) closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.