You are running an outdated Graylog version (Space Moose)

== Web UI says ==
You are running an outdated Graylog version
The most recent stable Graylog version is 3.0.1 (Space Moose) release at 2019-0401T00:00:00:000Z

But our server is already on 3.0.1-2 coz it’s our initial build using the latest version:

== rpm -qa|grep graylog ==

did you restart the server after the rpm upgrade?

it’s not an upgrade but an initial setup from this latest version and yes we restarted the service several times

Same issue. 3.0 appliance which we upgraded yesterday as per docs. Now have the same banner message in the GUI:

The most recent stable Graylog version is 3.0.1 (Space Moose) release at 2019-0401T00:00:00:000Z

ubuntu@graylog:~$ sudo apt list | grep graylog

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

graylog-3.0-repository/stable,stable,now 1-6 all [installed]
graylog-enterprise-integrations-plugins/stable,stable 3.0.1-2 all
graylog-enterprise-plugins/stable,stable,now 3.0.1-2 all [installed]
graylog-integrations-plugins/stable,stable 3.0.1-2 all
graylog-server/stable,stable,now 3.0.1-2 all [installed]

does that message have a “x” in the left right? that you can remove that message?

Yes there is. The “x” icon is for deleting the notification which we did (for example yesterday but the same notification came back today morning)

what is the current time on your system?

== timedatectl ;date ==
Local time: Thu 2019-05-02 13:33:22 PDT
Universal time: Thu 2019-05-02 20:33:22 UTC
RTC time: Thu 2019-05-02 20:33:22
Time zone: America/Los_Angeles (PDT, -0700)
NTP enabled: yes
NTP synchronized: yes
RTC in local TZ: no
DST active: yes
Last DST change: DST began at
Sun 2019-03-10 01:59:59 PST
Sun 2019-03-10 03:00:00 PDT
Next DST change: DST ends (the clock jumps one hour backwards) at
Sun 2019-11-03 01:59:59 PDT
Sun 2019-11-03 01:00:00 PST
Thu May 2 13:33:22 PDT 2019


Could you please enable debug logging for the version check to help us figure out what is happening here?
You’d need to supply a log4j configuration to the master node (e.g. taking the default file from ) as explained at and change the line from off to debug and restart the master node.

After about 5 minutes there should be information in the server log file about the performed version check. This check only runs on the configured master node and you only need to make the change there.


Just for the chain. My message cleared after a couple of restarts.

This is what the log says using the debug option:

== /var/log/graylog-server/server.log ==
2019-05-08T13:25:05.912-07:00 DEBUG [VersionCheckThread] Version check reports current version: 3.0.1 (Space Moose) released at 2019-04-01T00:00:00.000Z
2019-05-08T13:25:05.913-07:00 DEBUG [VersionCheckThread] Reported version is not higher than ours (3.0.2+1686930).

Few mins after bouncing the service, the annoying notification is also gone in the UI. Consider this resolved if you don’t hear back from us in a day or two, we’ll observe for now.

we have two separate instances and both worked after a quick service restart, no more annoying false notification. Can’t believe I missed that but thanks…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.