Valid metadata Not Found at specific URL

1. Describe your incident:
I tried to install GRAYLOG. First several times I kept receiving an error when trying to import the keyring.gpg. Next, I tried the solution offered as a work around from a previous post mentioning there was a problem with the keyring. The result of the workaround attempt I received : Valid metadata not found a specified URL.

2. Describe your environment:

  • OS Information: SuSE

  • Package Version:

  • Service logs, configurations, and environment variables:
    There are none log wise. No real config as I haven’t gotten that far.

3. What steps have you already taken to try and solve the problem?
I have trashed a number of virtual machines (VMware 8), after installing all the other requirements like Mongodb, Opensearch.

4. How can the community help?

I would like to know if anyone ever got this to work install wise (Graylog-5.0.1) or do I need to throw in the towel and move on to another package like Elastic or the like.

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

hi @mongoose
It would be helpful to post the precise error messages here - otherwise it will be difficult to help you.

Presently the following issue received when I found that the original approach listed in documents was wrong with respect to gpg keys:

I did post the info you asked for a bit ago.

sorry, I don’t know an answer. maybe @gsmith can help?

I appreciate the help.

Hey @mongoose

From your screenshot your RPm doesnt look right. Should be something like this

rpm --import

Then add the repository file /etc/zypp/repos.d/graylog.repo with the following


After that, install the latest Graylog Open release with:

sudo zypper install graylog-server


sudo zypper install graylog-enterprise

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.