SLES installation is failing

1. Describe your incident:

I’m trying to install Graylog following these instructions but I’m getting this error.

rpm --import
error: key 1 not an armored public key.

2. Describe your environment:

  • OS Information: SUSE Linux Enterprise Server 15 SP3 (x86_64) - Kernel \r (\l).

3. What steps have you already taken to try and solve the problem?

I’ve tried downloading the file from and I’ve noticed it’s not a text file but seems a binary one. Might this be the issue?

4. How can the community help?

Has someone managed to install Graylog in SLES 15?
Am I right when I say that rpm --import is expecting a plain text certificate and not a binary?

Greetings! I was able to reproduce this same error. I’ll check with our devs internally to see if this is a known issue.

I did find out the instructions on that page have some errors. Still working internally to correct. You are correct in that the key file is wrong. The instructions on that page point to the deb key (which is binary) instead of the rpm key (which should be ascii).

In the meantime, i was able to at least install graylog-server on SUSE:

sudo rpm --import ''
sudo zypper addrepo --gpgcheck --refresh '$basearch' 'graylog'

When attempting to install, zypper does return a “file from repository is unsigned” warning:

Retrieving repository 'graylog' metadata ----------------------------------------------------------------------------[\]
Warning: File 'repomd.xml' from repository 'graylog' is unsigned.

    Note: Signing data enables the recipient to verify that no modifications occurred after the data
    were signed. Accepting data with no, wrong or unknown signature can lead to a corrupted system
    and in extreme cases even to a system compromise.

    Note: File 'repomd.xml' is the repositories master index file. It ensures the integrity of the
    whole repo.

    Warning: We can't verify that no one meddled with this file, so it might not be trustworthy
    anymore! You should not continue unless you know it's safe.

File 'repomd.xml' from repository 'graylog' is unsigned, continue? [yes/no] (no): yes

However, you can choose ‘yes’ at the prompt to continue. I understand this is not ideal and probably not recommended (to ignore signing) unless this is for testing or a lab of some sort.

We will work to resolve these issues. Thanks.

Hi Drew,
thanks for your support here!

I’ll probably wait for you to fix the official documentation so that I’ll have a clean install with no workarounds, it seems wiser :slight_smile:

Thanks again,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.