Upgrading ubuntu to 16.04 on existing graylog server


#1

Hello we are trying to upgrade ubuntu from 14.04.05 LTS to 16.04, after we perform the upgrade the graylog server won’t start. Any suggestions or something that we might have missed?

thanks


(Philipp Ruland) #2

Hey :slight_smile:

Can you post the last few lines of your Graylog log file (until the shutdown of the last start), this could give valuable hints about the problem :slight_smile:

Greetings - Phil


#3

We reverted back to our snapshot before trying to perform the upgrade. I was more looking to see if anyone has done this, and if there are any additional steps that need to be performed to get the existing graylog installation to work after ubuntu has been updated.


(Jochen) #4

Graylog works on Ubuntu Linux 14.04.x and on Ubuntu Linux 16.04, so I guess it was some problem induced by your upgrade procedure.

Since you provided no details whatsoever, we can only guess… :crystal_ball:


#5

we just ran sudo do-release-upgrade, after the server rebooted graylog did not work. I was just curious if there is a step that needs performed after this has been performed. thanks


(Jochen) #6

What does “graylog did not work” mean exactly?


#7

The web interface doesn’t launch


(Jochen) #8

What do the logs of your Graylog and Elasticsearch instances say?

See http://docs.graylog.org/en/2.2/pages/configuration/file_location.html#deb-package for the specific file locations.


#9

well since it didn’t seem to be working we reverted back to our snapshot before starting the upgrade. I was just curious if there were any steps that needed to be performed after the ubuntu upgrade.


(Philipp Ruland) #10

Hey @service1stis,

it is very difficult and basically impossible to help you without knowing details. Could you please post your​ Graylog log file? Else we won’t have a chance to help you.

Greetings - Phil