Upgrading to Graylog 5.0 Broke Enterprise Functionality

1. Describe your incident:

We use Graylog Enterprise/Operations with the Small Business license. At first we weren’t using Enterprise at all so we had initially installed only the graylog-server package from the normal Graylog repository on our RHEL 8 system.

We were then able to add the Enterprise functionality later on by installing the graylog-enterprise-plugins package, alongside the graylog-server package, as the documentation at the time indicated to do.

However, when upgrading from 4.3.12 → 5.0.5, the graylog-enterprise-plugins package was obsoleted and no longer exists in the 5.x repo. In the upgrade guide, it said to remove the plugins packages (including graylog-enterprise-plugins) before updating Graylog, so that’s what we did.

Now we’re only left with the graylog-server package. The Enterprise page now shows that the “Graylog Plugin Enterprise is not installed”, even though there really isn’t any Enterprise “Plugins” package to install anymore. There’s only the graylog-enterprise package.

These were the commands I ran to do the upgrade:

# Switched the repo to the 5.x version
yum clean all
yum remove graylog-integrations-plugins graylog-enterprise-plugins graylog-enterprise-integrations-plugins
yum install graylog-server

Why was this done exactly?

What is the best way to fix this at this point without loosing any configuration or data?

I’m surprised that there doesn’t appear to be a migration route from Graylog Open to Graylog Enterprise (e.g. if you start with Graylog Open and switch to Enterprise at a later date). Or am I missing something?

Thank you.

2. Describe your environment:

  • OS Information: RHEL 8

  • Package Version:
    Currently running graylog-server-5.0.5-1.x86_64
    Upgraded from graylog-server-4.3.12-1.noarch

  • Service logs, configurations, and environment variables:
    I don’t think it’s relevant what the configuration is, since this is more a packaging/install issue, but I can send the info along if someone thinks it would be helpful.

3. What steps have you already taken to try and solve the problem?
Tried re-installing the graylog-enterprise-plugins package, but it no longer exists in the 5.x repository. Tried installing the graylog-enterprise package but got a bunch of yum conflict errors.

Hey @mattvw

Graylog Server 4.3 had multiple package to install


Now there are only two.

  • yum install graylog-server
  • yum install graylog-enterprise

Not sure if you seen this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.