Upgraded from 2.4 to 2.5, still running 2.4 after restart


#1

Hi,

I just upgraded from 2.4 to 2.5 using the deb repository and upgrade docs. Everything seemed to go fine, but when I either issue a systemctl restart or reboot the server, it still comes back up running the older 2.4.6 version. How can I get it to switch over to 2.5?

Thanks!


(Jan Doberstein) #2

He

did you reload your browser? It can happen that if you leave your browser window open during the update and the reboot and did not do a “full reload” of the page it looks like you have not updated.

What can you see in your Graylog server.log? Graylog is writing it’s version to the logfile.

Jan


#3

Hi Jan,

Reloading my browser did it, I should’ve tried that before posting. Thank you!


(Prakash A) #4

Dear @rhp, Could you please check the /usr/share/graylog-server/plugin/ folders. Maybe we can see if the graylog has been updated properly then you will get the updated plugins like graylog-plugin-threatintel-2.5.0.jar. This is also one option from CLI.