Inconsistent state after 2.2.3 update


(Ryan Tanay) #1

Updated Graylog via apt after receiving the notice for the 2.2.3 release. Apt believes Graylog is now up to date, but upon restarting the service, the Graylog footer remains “Graylog 2.2.2+691b4b7”

Additionally many parts of Graylog are now broken. New logs are being processed properly, but the Streams and Alerts pages contain only the header bar and the footer text.

Under System/Authentication, clicking edit on any user results in a blank frame, as does clicking the roles link in the left navigation bar.

Any assistance would be appreciated.


(Ryan Tanay) #2

Followup:

After rolling back Graylog to 2.2.2 to no effect whatsoever I rolled it forward again, also to no effect.

Looking through the dashboards (which still worked) I clicked on the “play” button on one of the tiles, got the “we are preparing Graylog for you” message, and suddenly everything worked.

Super weird, but hopefully this helps somebody.


(Jan Doberstein) #3

hej @rtanay

that happen if you leave the Graylog Webinterface open in your browser, do the upgrade and did not perform a full-page-reload after Graylog is back online.

regards
Jan