Upgrade from 2.2 to 2.3 fails


(Mirackle Spb) #1

hi all
is anybody already upgraded graylog to 2.3 ?
I upgraded deb installation on my ubuntu 16.04.
After upgrade system faled to start with strange error message at startup “Guice error (more detail on log level debug): No implementation for java.util.Set<org.jboss.netty.handler.ipfilter.IpSubnet> annotated with @com.google.inject.name.Named(value=trusted_proxies) was bound.”?
How you fixed it?


(Jochen) #2

This error is caused by an old plugin which is incompatible with Graylog 2.3.x.
Make sure to use the latest versions of your plugins.


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.