Upgrade from 2.2.3 to 2.3


(Matt) #1

I followed the steps in documentation as follows. These steps have served me well on previous upgrades but this time to no avail.

$ wget https://packages.graylog2.org/repo/packages/graylog-2.3-repository_latest.deb
$ sudo dpkg -i graylog-2.3-repository_latest.deb
$ sudo apt-get update
$ sudo apt-get install graylog-server

However when finished I get the following.

root@graylog02:/home/cfsadmin# sudo apt-get install graylog-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
graylog-server is already the newest version (2.2.3-1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-87 linux-headers-4.4.0-87-generic linux-headers-4.4.0-92 linux-headers-4.4.0-92-generic linux-
headers-4.4.0-93 linux-headers-4.4.0-93-generic linux-headers-4.4.0-96 linux-headers-4.4.0-96-generic
  linux-image-4.4.0-87-generic linux-image-4.4.0-92-generic linux-image-4.4.0-93-generic linux-image-4.4.0-96-
generic linux-image-extra-4.4.0-87-generic linux-image-extra-4.4.0-92-generic linux-image-extra-4.4.0-93-generic
  linux-image-extra-4.4.0-96-generic
 Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 137 not upgraded.

The line that states graylog server is already at the newest version is interesting to me. Any Ideas? Did I miss something simple? Servers are working great but of course are still at the old version.


(Jan Doberstein) #2

@Mantil

what output did you get from dpkg -l | grep gray ?

The above is working nice for all my test servers.


(Matt) #3

I should have pulled this. I found the issue wasn’t with the package at all. Was our network admin implementing some type of DPI on our firewall that caused some cert errors. As such any site or outside repository I tried to download from wasn’t “trusted”. Once I had him remove the policy all worked just fine. Well at least for the upgrade. Getting it to connect to the old elasticsearch cluster is another problem entirely that I haven’t cracked so I reverted the updates. But that is for another thread I have actually already posted. I will be working on that one this week once I get back into the office.
Upgrading Graylog

Thank you for the reply though


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.